码迷,mamicode.com
首页 > 其他好文 > 详细

poj 2777 Count Color(线段树、状态压缩、位运算)

时间:2015-07-27 13:19:11      阅读:133      评论:0      收藏:0      [点我收藏+]

标签:poj   位运算   压缩   

Count Color
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 38921   Accepted: 11696

Description

Chosen Problem Solving and Program design as an optional course, you are required to solve all kinds of problems. Here, we get a new problem.

There is a very long board with length L centimeter, L is a positive integer, so we can evenly divide the board into L segments, and they are labeled by 1, 2, ... L from left to right, each is 1 centimeter long. Now we have to color the board - one segment with only one color. We can do following two operations on the board:

1. "C A B C" Color the board from segment A to segment B with color C.
2. "P A B" Output the number of different colors painted between segment A and segment B (including).

In our daily life, we have very few words to describe a color (red, green, blue, yellow…), so you may assume that the total number of different colors T is very small. To make it simple, we express the names of colors as color 1, color 2, ... color T. At the beginning, the board was painted in color 1. Now the rest of problem is left to your.

Input

First line of input contains L (1 <= L <= 100000), T (1 <= T <= 30) and O (1 <= O <= 100000). Here O denotes the number of operations. Following O lines, each contains "C A B C" or "P A B" (here A, B, C are integers, and A may be larger than B) as an operation defined previously.

Output

Ouput results of the output operation in order, each line contains a number.

Sample Input

2 2 4
C 1 1 2
P 1 2
C 2 2 2
P 1 2

Sample Output

2
1

Source

POJ Monthly--2006.03.26,dodo

题目大意:给某个区间染色,然后输出某个区间的颜色数目。
线段树的题目。因为颜色最多只有30种,所以可以用一个整型变量来存储颜色,每一位代表一个颜色。用color代表颜色数量,add用于延迟更新。如果add为0,表明不需要更新。对于两个区间的合并,判断颜色数量时,只要用或运算就可以,所以就很方便。注意A有可能小于B。
#include<stdio.h>
#include<string.h>
#define M 100005
struct tree{
	int l,r,color,add;
}tree[M<<2];
void pushup(int root)
{
	if(tree[root].l==tree[root].r)return;
	tree[root].color=tree[root<<1].color|tree[root<<1|1].color;   //子节点的颜色种类更新到父节点。
	return;
}
void pushdown(int root)
{
	if(tree[root].l==tree[root].r)return ;
	if(tree[root].add==0)return;
	tree[root<<1].add=tree[root<<1|1].add=tree[root].add;
	tree[root<<1].color=tree[root].color;
	tree[root<<1|1].color=tree[root].color;
	tree[root].add=0;
	return;
	
}
void build(int l,int r,int root){
	tree[root].l=l;
	tree[root].r=r;
	tree[root].color=1;
	tree[root].add=0;
	if(l==r)return ;
	int mid=l+r>>1;
	build(l,mid,root<<1);
	build(mid+1,r,root<<1|1);
}
void update(int l,int r,int z,int root)
{
	if(tree[root].l==l&&tree[root].r==r){
		tree[root].color=1<<(z-1);
		tree[root].add=z;
		return;
	}
	pushdown(root);
	int mid=tree[root].l+tree[root].r>>1;
	if(r<=mid)update(l,r,z,root<<1);
	else if(l>mid)update(l,r,z,root<<1|1);
	else {
		update(l,mid,z,root<<1);
		update(mid+1,r,z,root<<1|1);
	}
	pushup(root);
}
int query(int l,int r,int root)
{
	if(tree[root].l==l&&tree[root].r==r)
	{
		return tree[root].color;
	}
	pushdown(root);
	int mid=tree[root].l+tree[root].r>>1;
	if(r<=mid)return query(l,r,root<<1);
	else if(l>mid)return query(l,r,root<<1|1);
	else {
		return query(l,mid,root<<1)|query(mid+1,r,root<<1|1);   //颜色合并巧妙使用位运算
	}
}
int cal(int x)
{
	int ans=0;
	while(x)
	{
		ans+=x%2;
		x=x/2;
	}
	return ans;
}
int main()
{
	int L,T,O,i,j,k,a,b,c;
	char s[20];
	while(scanf("%d%d%d",&L,&T,&O)!=EOF)
	{
		build(1,L,1);
		while(O--)
		{
		scanf("%s%d%d",s,&a,&b);
		if(a>b){
			int t=a;
			a=b;
			b=t;
		}
		if(s[0]=='C'){
			scanf("%d",&c);
			update(a,b,c,1);
		}
		if(s[0]=='P'){
			int ans=query(a,b,1);
			ans=cal(ans);
			printf("%d\n",ans);
		}
		}
	}
	return 0;
}



版权声明:本文为博主原创文章,未经博主允许不得转载。

poj 2777 Count Color(线段树、状态压缩、位运算)

标签:poj   位运算   压缩   

原文地址:http://blog.csdn.net/aaaaacmer/article/details/47082435

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!