标签:hdu 区域赛 动态规划
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5074
题面:
Hatsune Miku
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 810 Accepted Submission(s): 577
Problem Description
Hatsune Miku is a popular virtual singer. It is very popular in both Japan and China. Basically it is a computer software that allows you to compose a song on your own using the vocal package.
Today you want to compose a song, which is just a sequence of notes. There are only m different notes provided in the package. And you want to make a song with n notes.
Also, you know that there is a system to evaluate the beautifulness of a song. For each two consecutive notes a and b, if b comes after a, then the beautifulness for these two notes is evaluated as score(a, b).
So the total beautifulness for a song consisting of notes a
1, a
2, . . . , a
n, is simply the sum of score(a
i, a
i+1) for 1 ≤ i ≤ n - 1.
Now, you find that at some positions, the notes have to be some specific ones, but at other positions you can decide what notes to use. You want to maximize your song’s beautifulness. What is the maximum beautifulness you can achieve?
Input
The first line contains an integer T (T ≤ 10), denoting the number of the test cases.
For each test case, the first line contains two integers n(1 ≤ n ≤ 100) and m(1 ≤ m ≤ 50) as mentioned above. Then m lines follow, each of them consisting of m space-separated integers, the j-th integer in the i-th line for score(i, j)( 0 ≤ score(i, j) ≤ 100).
The next line contains n integers, a1, a2, . . . , an (-1 ≤ ai ≤ m, ai ≠ 0), where positive integers stand for the notes you cannot change, while negative integers are what you can replace with arbitrary
notes. The notes are named from 1 to m.
Output
For each test case, output the answer in one line.
Sample Input
2
5 3
83 86 77
15 93 35
86 92 49
3 3 3 1 2
10 5
36 11 68 67 29
82 30 62 23 67
35 29 2 22 58
69 67 93 56 11
42 29 73 21 19
-1 -1 5 -1 4 -1 -1 -1 4 -1
Sample Output
Source
解题:
dp[i][j]代表的是在i位置选用j的最大值。最外面循环i代表当前位置,如果i不固定,双层循环,分别循环dp[i+1][j]=max(dp[i+1][j],dp[i][k]+val[k][j]);如果当前点已经固定了,那么单层循环k,dp[i+1][j]=max(dp[i+1][j],dp[i][k]+val[k][j])。同时需考虑后续点是否也已经固定了。
代码:
#include <iostream>
#include <cstring>
#include <cstdio>
#include <cstdlib>
using namespace std;
int val[55][55],dp[105][55],pos[105],p,ans;
int t,n,m;
int max(int a,int b)
{
return a>b?a:b;
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&m);
memset(val,0,sizeof(val));
memset(dp,0,sizeof(dp));
for(int i=1;i<=m;i++)
{
for(int j=1;j<=m;j++)
scanf("%d",&val[i][j]);
}
for(int i=1;i<=n;i++)
{
scanf("%d",&pos[i]);
}
for(int i=2;i<=n;i++)
{
p=pos[i];
if(pos[i]>0)
{
if(pos[i-1]>0)
dp[i][p]=dp[i-1][pos[i-1]]+val[pos[i-1]][p];
else
for(int j=1;j<=m;j++)
dp[i][p]=max(dp[i][p],dp[i-1][j]+val[j][p]);
}
else
{
if(pos[i-1]>0)
for(int j=1;j<=m;j++)
dp[i][j]=dp[i-1][pos[i-1]]+val[pos[i-1]][j];
else
{
for(int j=1;j<=m;j++)
for(int k=1;k<=m;k++)
dp[i][j]=max(dp[i][j],dp[i-1][k]+val[k][j]);
}
}
}
ans=0;
for(int i=1;i<=m;i++)
ans=max(ans,dp[n][i]);
printf("%d\n",ans);
}
return 0;
}
版权声明:本文为博主原创文章,未经博主允许不得转载。
HDU 5074 Hatsune Miku
标签:hdu 区域赛 动态规划
原文地址:http://blog.csdn.net/david_jett/article/details/47082847