码迷,mamicode.com
首页 > 其他好文 > 详细

hdu1325 Is It A Tree?(二叉树的判断)

时间:2015-07-27 21:02:07      阅读:156      评论:0      收藏:0      [点我收藏+]

标签:hdu1325   hdu 1325   二叉树   

Is It A Tree?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17520    Accepted Submission(s): 3939


Problem Description
A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 
There is exactly one node, called the root, to which no directed edges point. 

Every node except the root has exactly one edge pointing to it. 

There is a unique sequence of directed edges from the root to each node. 

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.

技术分享技术分享技术分享


In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not. 

 

Input
The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero. 
 

Output
For each test case display the line ``Case k is a tree." or the line ``Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1). 
 

Sample Input
6 8 5 3 5 2 6 4 5 6 0 0 8 1 7 3 6 2 8 9 7 5 7 4 7 8 7 6 0 0 3 8 6 8 6 4 5 3 5 6 5 2 0 0 -1 -1
 

Sample Output
Case 1 is a tree. Case 2 is a tree. Case 3 is not a tree.
 

Source
 

Recommend
Ignatius.L   |   We have carefully selected several similar problems for you:  1856 1102 1301 1162 1198 
 

Statistic | Submit | Discuss | Note

这道题 我已经无力吐槽了、虽然和这道题(hdu1272)很像,可也只能是很像、、这道题有方向。就这些。

1.0 0也是一棵树

2.不是-1 -1结束,而是两个数同时小于0结束,否则会导致TLE

3.我用并查集判断是否成环,然后判断顶点数是否等于边数+1。可是wa了。。

4.最后我没有用并查集,仅仅是判断出度和顶点数是否等于边数+1,A了

5.在这里我判断边数用的set容器。因为在set容器里面如果有重复的数字,会只记一次

我不说了。看代码把、o(︶︿︶)o 唉

#include<stdio.h>
#include <string.h>
#include <set>
using namespace std;
int fa[1005],ru[1005];
int main()
{
    set<int>s;
    int a,b,edgs,t=1;
    while(scanf("%d %d",&a,&b)!=EOF)
    {
        if(a<0&&b<0)
        break;
        if(a==0&&b==0)
        {
             printf("Case %d is a tree.\n",t++);
            continue;
        }
        memset(ru,0,sizeof(ru));
        ru[b]++;
        s.clear();//一定要记得
        edgs=1;
        s.insert(a),s.insert(b);
        while(1)
        {
            scanf("%d %d",&a,&b);
            if(a==0&&b==0)
            break;
            edgs++,ru[b]++;
            s.insert(a),s.insert(b);
        }
        int flag=1;
        for(int i=0;i<1005;i++)
        if(ru[i]>1)
        flag=0;
        if(s.size()==edgs+1&&flag)
        printf("Case %d is a tree.\n",t++);
        else
        printf("Case %d is not a tree.\n",t++);
    }
    return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

hdu1325 Is It A Tree?(二叉树的判断)

标签:hdu1325   hdu 1325   二叉树   

原文地址:http://blog.csdn.net/su20145104009/article/details/47089945

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!