码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1265:Area

时间:2014-07-09 11:21:01      阅读:234      评论:0      收藏:0      [点我收藏+]

标签:poj

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 4725   Accepted: 2135

Description

Being well known for its highly innovative products, Merck would definitely be a good target for industrial espionage. To protect its brand-new research and development facility the company has installed the latest system of surveillance robots patrolling the area. These robots move along the walls of the facility and report suspicious observations to the central security office. The only flaw in the system a competitor抯 agent could find is the fact that the robots radio their movements unencrypted. Not being able to find out more, the agent wants to use that information to calculate the exact size of the area occupied by the new facility. It is public knowledge that all the corners of the building are situated on a rectangular grid and that only straight walls are used. Figure 1 shows the course of a robot around an example area. 

bubuko.com,布布扣 
Figure 1: Example area. 

You are hired to write a program that calculates the area occupied by the new facility from the movements of a robot along its walls. You can assume that this area is a polygon with corners on a rectangular grid. However, your boss insists that you use a formula he is so proud to have found somewhere. The formula relates the number I of grid points inside the polygon, the number E of grid points on the edges, and the total area A of the polygon. Unfortunately, you have lost the sheet on which he had written down that simple formula for you, so your first task is to find the formula yourself. 

Input

The first line contains the number of scenarios. 
For each scenario, you are given the number m, 3 <= m < 100, of movements of the robot in the first line. The following m lines contain pairs 揹x dy?of integers, separated by a single blank, satisfying .-100 <= dx, dy <= 100 and (dx, dy) != (0, 0). Such a pair means that the robot moves on to a grid point dx units to the right and dy units upwards on the grid (with respect to the current position). You can assume that the curve along which the robot moves is closed and that it does not intersect or even touch itself except for the start and end points. The robot moves anti-clockwise around the building, so the area to be calculated lies to the left of the curve. It is known in advance that the whole polygon would fit into a square on the grid with a side length of 100 units. 

Output

The output for every scenario begins with a line containing 揝cenario #i:? where i is the number of the scenario starting at 1. Then print a single line containing I, E, and A, the area A rounded to one digit after the decimal point. Separate the three numbers by two single blanks. Terminate the output for the scenario with a blank line.

Sample Input

2
4
1 0
0 1
-1 0
0 -1
7
5 0
1 3
-2 2
-1 0
0 -3
-3 1
0 -3

Sample Output

Scenario #1:
0 4 1.0

Scenario #2:
12 16 19.0

分析:

Pick定理:一个计算公式中顶点在格点上的多边形 面积公式 :S=a+b÷2-1,其中a表示多边形内部的点数,b表示多边形边界上的点数,s表示多边形的面积。


如图:样例二



bubuko.com,布布扣



题目要求输出内部格点个数、边界格点个数、其面积。


1).多边形面积求解公式:

bubuko.com,布布扣                     bubuko.com,布布扣



     2). 多边形边界上的点数:

             两顶点连线构成边界。

             两顶点连线中(边界)所经过的点数即为,两顶点分别各自横纵坐标的差的最大公约数。

    3)多边形内的点:

        inside =  area+1 -  boundary/2;


#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<cmath>

using namespace std;

const int M = 1000 + 5;
int area;
int inside;
int boundary;
int x[M];
int y[M];
int p[M];
int q[M];

int boundary_work(int a, int b)
{
    int t;
    while( b )
    {
        t=b;
        b=a%b;
        a=t;
    }
    return a;
}

int area_work(int a, int b, int c, int d)
{
    return (a*d-b*c);
}

int main()
{
    int n, m;
    scanf("%d", &n);
    for(int cas=1; cas<=n; cas++)
    {
        scanf("%d", &m);
        p[0]=0; q[0]=0;
        inside=0; boundary=0; area=0;
        for(int i=1; i<=m; i++)
        {
            scanf("%d%d", &x[i], &y[i]);
            p[i]=p[i-1]+x[i];
            q[i]=q[i-1]+y[i];
            area += area_work( p[i-1], q[i-1], p[i], q[i] );
            boundary += boundary_work( abs(x[i]), abs(y[i]) );
        }
        inside = area/2+1-boundary/2;
        printf("Scenario #%d:\n%d %d %.1f\n\n", cas, inside, boundary, (double(area)/2));
    }

    return 0;
}

POJ 1265:Area,布布扣,bubuko.com

POJ 1265:Area

标签:poj

原文地址:http://blog.csdn.net/u013487051/article/details/37575951

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!