码迷,mamicode.com
首页 > 其他好文 > 详细

poj 2594 Treasure Exploration 二分图匹配

时间:2015-07-27 23:09:40      阅读:156      评论:0      收藏:0      [点我收藏+]

标签:acm

点击打开链接题目链接

Treasure Exploration
Time Limit: 6000MS   Memory Limit: 65536K
Total Submissions: 7215   Accepted: 2947

Description

Have you ever read any book about treasure exploration? Have you ever see any film about treasure exploration? Have you ever explored treasure? If you never have such experiences, you would never know what fun treasure exploring brings to you. 
Recently, a company named EUC (Exploring the Unknown Company) plan to explore an unknown place on Mars, which is considered full of treasure. For fast development of technology and bad environment for human beings, EUC sends some robots to explore the treasure. 
To make it easy, we use a graph, which is formed by N points (these N points are numbered from 1 to N), to represent the places to be explored. And some points are connected by one-way road, which means that, through the road, a robot can only move from one end to the other end, but cannot move back. For some unknown reasons, there is no circle in this graph. The robots can be sent to any point from Earth by rockets. After landing, the robot can visit some points through the roads, and it can choose some points, which are on its roads, to explore. You should notice that the roads of two different robots may contain some same point. 
For financial reason, EUC wants to use minimal number of robots to explore all the points on Mars. 
As an ICPCer, who has excellent programming skill, can your help EUC?

Input

The input will consist of several test cases. For each test case, two integers N (1 <= N <= 500) and M (0 <= M <= 5000) are given in the first line, indicating the number of points and the number of one-way roads in the graph respectively. Each of the following M lines contains two different integers A and B, indicating there is a one-way from A to B (0 < A, B <= N). The input is terminated by a single line with two zeros.

Output

For each test of the input, print a line containing the least robots needed.

Sample Input

1 0
2 1
1 2
2 0
0 0

Sample Output

1
1
2
某条路径可以重复走多次

用floyed求出可以到达的点

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#define MAXN 555
using namespace std;
int n,m;
bool g[MAXN][MAXN];
bool vis[MAXN];
int link[MAXN];
void init(){
    memset(vis,0,sizeof(vis));
    memset(link,-1,sizeof(link));
    memset(g,0,sizeof(g));
}
void floyed(){
    for(int i=0;i<n;i++){
        for(int j=0;j<n;j++){
            if(g[i][j]==0){
                for(int k=0;k<n;k++){
                    if(g[i][k]&&g[k][j]){
                        g[i][j]=1;
                        break;
                    }
                }
            }
        }
    }
}
bool finds(int x){
    for(int i=0;i<n;i++){
        if(!vis[i]&&g[x][i]){
            vis[i]=1;
            if(link[i]==-1||finds(link[i])){
                link[i]=x;
                return 1;
            }
        }
    }
    return 0;
}
int main(){
    while(scanf("%d %d",&n,&m)&&(n||m)){
        init();
        int st,ed;
        for(int i=1;i<=m;i++){
            scanf("%d %d",&st,&ed);
            st--;
            ed--;
            g[st][ed]=1;
        }
        floyed();
        int ans=0;
        for(int i=0;i<n;i++){
            memset(vis,0,sizeof(vis));
            if(finds(i))
                ans++;
        }
        printf("%d\n",n-ans);
    }
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

poj 2594 Treasure Exploration 二分图匹配

标签:acm

原文地址:http://blog.csdn.net/qq_16843991/article/details/47090985

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!