标签:acm hdu
Anniversary party
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6408 Accepted Submission(s): 2867
Problem Description
There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make
the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your
task is to make a list of guests with the maximal possible sum of guests‘ conviviality ratings.
Input
Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127.
After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0
Output
Output should contain the maximal sum of guests‘ ratings.
Sample Input
7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0
Sample Output
Source
dp[u][1] 表示取u点 dp[u][0]表示不取u点,
则递推: dp(root, 0) = 西格玛 max(dp(e(root, i), 1) + dp(e(root, i), o))
dp(root, 1) = a[root] + 西格玛(dp(e(root, i), 0)).
#include<cstdio>
#include<cmath>
#include<stdlib.h>
#include<map>
#include<set>
#include<time.h>
#include<vector>
#include<queue>
#include<string>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
#define eps 1e-8
#define INF 0x3f3f3f3f
#define max(a,b) ((a)>(b)?(a):(b))
#define min(a,b) ((a)<(b)?(a):(b))
#define maxn 6000 + 10
int n, a[maxn], head[maxn], tot;
int dp[maxn][2];
struct edge
{
int v, next;
}e[maxn*maxn];
void init()
{
tot = 0;
memset(head, -1, (n+2)*sizeof(int));
memset(dp, -1, sizeof(dp));
}
void adde(int u, int v)
{
e[tot].v = v; e[tot].next = head[u]; head[u] = tot++;
}
void dfs(int u, int fa)
{
int M0, M1;
M0 = 0;
M1 = a[u];
for(int i=head[u]; i!=-1; i=e[i].next)
{
int v = e[i].v;
if(v == fa) continue;
dfs(v, u);
M0 += max(dp[v][0], dp[v][1]);
M1 += dp[v][0];
}
dp[u][0] = M0;
dp[u][1] = M1;
}
int main()
{
while(~scanf("%d", &n))
{
init();
for(int i=1; i<=n; i++)
scanf("%d", &a[i]);
int u, v;
while(scanf("%d%d", &u, &v) && u + v)
{
adde(u, v);
adde(v, u);
}
dfs(1, -1);
printf("%d\n", max(dp[1][0], dp[1][1]));
}
return 0;
}
版权声明:本文为博主原创文章,未经博主允许不得转载。
HDU 1520
标签:acm hdu
原文地址:http://blog.csdn.net/dojintian/article/details/47102003