码迷,mamicode.com
首页 > 其他好文 > 详细

LA-3882 And Then There Was One

时间:2014-07-09 10:00:13      阅读:172      评论:0      收藏:0      [点我收藏+]

标签:la

3882 - And Then There Was One

Time limit: 3.000 seconds 

Let‘s play a stone removing game.

Initially, n stones are arranged on a circle and numbered 1,..., n clockwise (Figure 1). You are also given two numbers k and m . From this state, remove stones one by one following the rules explained below, until only one remains. In step 1, remove stone m . In step 2, locate the k -th next stone clockwise from m and remove it. In subsequent steps, start from the slot of the stone removed in the last step, make k hops clockwise on the remaining stones and remove the one you reach. In other words, skip (k - 1) remaining stones clockwise and remove the next one. Repeat this until only one stone is left and answer its number.

For example, the answer for the case n = 8 , k = 5 , m = 3 is 1, as shown in Figure 1.

bubuko.com,布布扣

Figure 1: An example game


Initial state: Eight stones are arranged on a circle.

Step 1: Stone 3 is removed since m = 3 .

Step 2: You start from the slot that was occupied by stone 3. You skip four stones 4, 5, 6 and 7 (since k = 5 ), and remove the next one, which is 8.

Step 3: You skip stones 1, 2, 4 and 5, and thus remove 6. Note that you only count stones that are still on the circle and ignore those already removed. Stone 3 is ignored in this case.

Steps 4-7: You continue until only one stone is left. Notice that in later steps when only a few stones remain, the same stone may be skipped multiple times. For example, stones 1 and 4 are skipped twice in step 7.

Final State: Finally, only one stone, 1, is on the circle. This is the final state, so the answer is 1.

Input 

The input consists of multiple datasets each of which is formatted as follows.


n k m


The last dataset is followed by a line containing three zeros. Numbers in a line are separated by a single space. A dataset satisfies the following conditions.

2bubuko.com,布布扣nbubuko.com,布布扣10000, 1bubuko.com,布布扣kbubuko.com,布布扣10000, 1bubuko.com,布布扣mbubuko.com,布布扣n

The number of datasets is less than 100.

Output 

For each dataset, output a line containing the stone number left in the final state. No extra characters such as spaces should appear in the output.

Sample Input 

8 5 3 
100 9999 98 
10000 10000 10000 
0 0 0

Sample Output 

1 
93 
2019

#include<cstdio>
const int maxn = 10000+2;
int f[maxn];
int main()
{
	int n,k,m;
	while(scanf("%d%d%d",&n,&k,&m)==3&&n)
	{
		f[1]=0;
		for(int i=2;i<=n;i++) 
			f[i]=(f[i-1]+k)%i;
		int ans=(m-k+1+f[n])%n;
		if(ans<=0)
			ans+=n;
		printf("%d\n",ans);
	}
	return 0;
} 

LA-3882 And Then There Was One,布布扣,bubuko.com

LA-3882 And Then There Was One

标签:la

原文地址:http://blog.csdn.net/justesss/article/details/37566647

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!