码迷,mamicode.com
首页 > 其他好文 > 详细

1218THE DRUNK JAILER

时间:2015-07-28 16:01:53      阅读:82      评论:0      收藏:0      [点我收藏+]

标签:

THE DRUNK JAILER
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 25010   Accepted: 15692

Description

A certain prison contains a long hall of n cells, each right next to each other. Each cell has a prisoner in it, and each cell is locked.
One night, the jailer gets bored and decides to play a game. For round 1 of the game, he takes a drink of whiskey,and then runs down the hall unlocking each cell. For round 2, he takes a drink of whiskey, and then runs down the
hall locking every other cell (cells 2, 4, 6, ?). For round 3, he takes a drink of whiskey, and then runs down the hall. He visits every third cell (cells 3, 6, 9, ?). If the cell is locked, he unlocks it; if it is unlocked, he locks it. He
repeats this for n rounds, takes a final drink, and passes out.
Some number of prisoners, possibly zero, realizes that their cells are unlocked and the jailer is incapacitated. They immediately escape.
Given the number of cells, determine how many prisoners escape jail.

Input

The first line of input contains a single positive integer. This is the number of lines that follow. Each of the following lines contains a single integer between 5 and 100, inclusive, which is the number of cells n.

Output

For each line, you must print out the number of prisoners that escape when the prison has n cells.

Sample Input

2
5
100

Sample Output

2
10

Source

#include<iostream>
#include<cstring>

using namespace std;

int a[102];
int main()
{
	int T;
	cin>>T;
	while(T--)
	{
	int n;
	   cin>>n;
	   memset(a,0,sizeof(a));
	   for(int i=1;i<=n;i++)
	   {for(int j=1;j<=n;j++)
			if(j%i==0)
			{
				a[j]=!a[j];
			}
	   }
	   int count=0;
	   for(int i=1;i<=n;i++)
	   if(a[i]==1)
	   count++;

	   cout<<count<<endl;
	}
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

1218THE DRUNK JAILER

标签:

原文地址:http://blog.csdn.net/became_a_wolf/article/details/47106127

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!