码迷,mamicode.com
首页 > 其他好文 > 详细

POJ2406-Power Strings(kmp循环节)

时间:2014-07-09 11:11:53      阅读:155      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   color   strong   width   

Power Strings
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 31111   Accepted: 12982

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3
题意:输出循环节最大的个数

思路:next函数判断一下即可:
若n%(n-next[n])==0 ans = n/(n-next[n])
否则 ans = 1
#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <string>
#include <algorithm>
#include <queue>
using namespace std;
const int maxn = 1000000+10;
int next[maxn];
char str[maxn];
int n;
void getNext(){
    next[0] = next[1] = 0;
    for(int i = 1,j; i < n; i++){
        j = next[i];
        while(j && str[i] != str[j]) j = next[j];
        if(str[i]==str[j]) next[i+1] = j+1;
        else next[i+1] = 0;
    }
}
int main(){

    while(~scanf("%s",str) && strcmp(str,".")!=0){
        n = strlen(str);
        getNext();
        int ans;
        if(n%(n-next[n])!=0) ans = 1;
        else ans =  n/(n-next[n]);
        printf("%d\n",ans);
    }
    return 0;
}


POJ2406-Power Strings(kmp循环节),布布扣,bubuko.com

POJ2406-Power Strings(kmp循环节)

标签:des   style   blog   color   strong   width   

原文地址:http://blog.csdn.net/mowayao/article/details/37563955

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!