码迷,mamicode.com
首页 > 其他好文 > 详细

HDU3336-Count the string(KMP)

时间:2014-07-09 10:02:57      阅读:165      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   java   color   strong   

Count the string

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4449    Accepted Submission(s): 2094


Problem Description
It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: "abab"
The prefixes are: "a", "ab", "aba", "abab"
For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab", it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.
 

Input
The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.
 

Output
For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.
 

Sample Input
1 4 abab
 

Sample Output
6
 

Author
foreverlin@HNU
 

题目意思:统计所以前缀在原串出现的次数

思路:利用KMP next函数,next函数统计的就是前缀跟自身字符串匹配的信息。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <string>
#include <algorithm>
#include <queue>
using namespace std;
const int maxn =  200000+10;
const int MOD = 10007;
char str[maxn];
int next[maxn],n;
void getNext(){
    next[0] = next[1] = 0;
    int ans = n;
    for(int i = 1; i < n; i++){
        int j = next[i];
        while(j && str[i] !=str[j]) j = next[j];
        if(str[j] == str[i]){
            next[i+1] = j+1;
        }else{
            next[i+1] = 0;
        }
    }
}
int main(){

    int ncase;
    cin >> ncase;
    while(ncase--){
        scanf("%d%s",&n,str);
        getNext();
        int ans = n%MOD;
        for(int i = 1; i <= n; i++){
            if(next[i] !=0){
                ans = (ans+1)%MOD;
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}


HDU3336-Count the string(KMP),布布扣,bubuko.com

HDU3336-Count the string(KMP)

标签:des   style   blog   java   color   strong   

原文地址:http://blog.csdn.net/mowayao/article/details/37563117

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!