码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 5323 Solve this interesting problem

时间:2015-07-28 21:13:44      阅读:125      评论:0      收藏:0      [点我收藏+]

标签:

搜索。。。

Solve this interesting problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 422    Accepted Submission(s): 98


Problem Description
Have you learned something about segment tree? If not, don’t worry, I will explain it for you.
Segment Tree is a kind of binary tree, it can be defined as this:
- For each node u in Segment Tree, u has two values: Lu and Ru.
- If Lu=Ru, u is a leaf node. 
- If LuRu, u has two children x and y,with Lx=Lu,Rx=?Lu+Ru2?,Ly=?Lu+Ru2?+1,Ry=Ru.
Here is an example of segment tree to do range query of sum.

技术分享


Given two integers L and R, Your task is to find the minimum non-negative n satisfy that: A Segment Tree with root node‘s value Lroot=0 and Rroot=n contains a node u with Lu=L and Ru=R.
 

Input
The input consists of several test cases. 
Each test case contains two integers L and R, as described above.
0LR109
LR?L+12015
 

Output
For each test, output one line contains one integer. If there is no such n, just output -1.
 

Sample Input
6 7 10 13 10 11
 

Sample Output
7 -1 12
 

Source
 

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
#define prt(k) cout<<#k" = "<<k<<endl;
const ll inf = 1e18;
ll ans;
void dfs(ll L, ll R)
{
        if (R>=ans) return;
        if (L < 0) return;
        if(L==0) {
                ans = R;
                return;
        }
        if (R - L + 1 > L) return;
        dfs(2*L - R - 1,  R);
        dfs(2*L - R - 2, R);
        dfs(L, 2*R - L);
        dfs(L, 2*R - L + 1);
}
ll L, R;
int main()
{
        while (cin>>L>>R)
        {
                ans = inf;
                dfs(L, R);
                if (ans == inf) ans =  -1;
                cout<<ans<<endl;
        }
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

HDU 5323 Solve this interesting problem

标签:

原文地址:http://blog.csdn.net/oilover/article/details/47110227

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!