码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 5326 Work 水题

时间:2015-07-28 22:28:02      阅读:110      评论:0      收藏:0      [点我收藏+]

标签:

Work

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 225    Accepted Submission(s): 166


Problem Description
技术分享


It’s an interesting experience to move from ICPC to work, end my college life and start a brand new journey in company.
As is known to all, every stuff in a company has a title, everyone except the boss has a direct leader, and all the relationship forms a tree. If A’s title is higher than B(A is the direct or indirect leader of B), we call it A manages B.
Now, give you the relation of a company, can you calculate how many people manage k people. 
 

Input
There are multiple test cases.
Each test case begins with two integers n and k, n indicates the number of stuff of the company.
Each of the following n-1 lines has two integers A and B, means A is the direct leader of B.

1 <= n <= 100 , 0 <= k < n
1 <= A, B <= n
 

Output
For each test case, output the answer as described above.
 

Sample Input
7 2 1 2 1 3 2 4 2 5 3 6 3 7
 

Sample Output
2
 

Source
 
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5326

 

AC代码:

 1 #include <iostream>
 2 #include <cstdio>
 3 #include <cstring>
 4 #include <string>
 5 #include <cmath>
 6 #include <algorithm>
 7 #include <vector>
 8 #include <queue>
 9 #include <set>
10 #include <map>
11 #include <stack>
12 #include <limits.h>
13 using namespace std;
14 typedef long long LL;
15 #define y1 y234
16 #define MAXN 1000010 // 1e6
17 vector <int> edge[MAXN];
18 int n, k;
19 int sum[MAXN];
20 void DFS(int u) {
21     int res = 0;
22     int len = edge[u].size();
23     for(int i = 0; i < len; i++) {
24         int v = edge[u][i];
25         if(!sum[v]) {
26             DFS(v);
27         }
28         res++;
29         res += sum[v];
30     }
31     sum[u] = res;
32 }
33 int main() {
34     while(~scanf("%d%d", &n, &k)) {
35         int ans = 0;
36         memset(sum, 0sizeof(sum));
37         for(int i = 0; i <= n; i++) edge[i].clear();
38         for(int i = 0; i < n - 1; i++) {
39             int a, b;
40             scanf("%d%d",&a, &b);
41             edge[a].push_back(b);
42         }
43         for(int i = 1; i <= n; i++) {
44             if(sum[i]) continue;
45             DFS(i);
46         }
47         for(int i = 1; i <= n; i++) {
48             if(sum[i] == k) ans++;
49         }
50         printf("%d\n", ans);
51     }
52     return 0;

53 } 

hdu 5326 Work 水题

标签:

原文地址:http://www.cnblogs.com/gaoxiang36999/p/4684215.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!