码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 5319多校 模拟

时间:2015-07-28 23:14:32      阅读:180      评论:0      收藏:0      [点我收藏+]

标签:多校   模拟   

Problem Description
Mr. Hdu is an painter, as we all know, painters need ideas to innovate , one day, he got stuck in rut and the ideas dry up, he took out a drawing board and began to draw casually. Imagine the board is a rectangle, consists of several square grids. He drew diagonally, so there are two kinds of draws, one is like ‘\’ , the other is like ‘/’. In each draw he choose arbitrary number of grids to draw. He always drew the first kind in red color, and drew the other kind in blue color, when a grid is drew by both red and blue, it becomes green. A grid will never be drew by the same color more than one time. Now give you the ultimate state of the board, can you calculate the minimum time of draws to reach this state.
 

Input
The first line is an integer T describe the number of test cases.
Each test case begins with an integer number n describe the number of rows of the drawing board.
Then n lines of string consist of ‘R’ ‘B’ ‘G’ and ‘.’ of the same length. ‘.’ means the grid has not been drawn.
1<=n<=50
The number of column of the rectangle is also less than 50.
Output
Output an integer as described in the problem description.
 

Output
Output an integer as described in the problem description.
 

Sample Input
2 4 RR.B .RG. .BRR B..R 4 RRBB RGGB BGGR BBRR
 

Sample Output
3 6
 


扫描的时候把G看成B和R的组合。

遇到R或G的时候,向两个方向扫,同时把G变成B。

遇到B或G的时候,同理。


重复扫两遍


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#include<vector>
#include<map>
#include<set>
#include<cmath>
#define ll long long
using namespace std;
char Map[60][60];
int vis[60][60];
int n,m;
int in(int x,int y)
{
    if(x>=0&&x<n&&y>=0&&y<m)
        return 1;
    return 0;
}
int sao(int xx,int yy,int c)
{
    int x,y;
    if(c==1)
    {
        x = xx;
        y = yy;
        while(1)
        {
            if(in(x+1,y+1)&&!vis[x+1][y+1])
            {
                if(Map[x+1][y+1]=='R')
                {
                    vis[x+1][y+1] = 1;
                    x++,y++;

                }
                else if(Map[x+1][y+1]=='G')
                {

                    Map[x+1][y+1]='B';
                     x++,y++;
                }
                else
                    break;
            }
            else
                break;
        }
        x = xx;
        y = yy;
        while(1)
        {
            if(in(x-1,y-1)&&!vis[x-1][y-1])
            {
                if(Map[x-1][y-1]=='R')
                {
                    vis[x-1][y-1] = 1;
                    x--,y--;
                }
                else if(Map[x-1][y-1]=='G')
                {

                    Map[x-1][y-1]= 'B';
                     x--,y--;
                }
                else
                    break;
            }
            else
                break;
        }
    }
    else
    {
        x = xx;
        y = yy;
        while(1)
        {
            if(in(x+1,y-1)&&!vis[x+1][y-1])
            {
                if(Map[x+1][y-1]=='B')
                {
                    vis[x+1][y-1] = 1;
                    x++,y--;
                }
                else if(Map[x+1][y-1]=='G')
                {

                    Map[x+1][y-1] ='R';
                    x++,y--;
                }
                else
                    break;
            }
            else
                break;
        }
        x = xx;
        y = yy;
        while(1)
        {
            if(in(x-1,y+1)&&!vis[x-1][y+1])
            {
                if(Map[x-1][y+1]=='B')
                {
                    vis[x-1][y+1] = 1;
                    x--,y++;

                }
                else if(Map[x-1][y+1]=='G')
                {

                    Map[x-1][y+1] ='R';
                    x--,y++;
                }
                else
                    break;
            }
            else
                break;
        }
    }

    return 0;
}
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        memset(vis,0,sizeof(vis));
        scanf("%d",&n);
        for(int i=0; i<n; i++)
            scanf("%s",Map[i]);
        m = strlen(Map[0]);
        int sum = 0;
        for(int i=0; i<n; i++)
        {
            for(int j=0; j<m; j++)
            {
                if(vis[i][j])
                    continue;
                if(Map[i][j]=='.')
                    continue;

                sum++;
                if(Map[i][j]=='R'||Map[i][j]=='G')
                {
                    if(Map[i][j]=='R')
                        vis[i][j] = 1;
                    else
                        Map[i][j]='B';
                    sao(i,j,1);
                }
                else if(Map[i][j]=='B'||Map[i][j]=='G')
                {
                    if(Map[i][j]=='B')
                        vis[i][j] = 1;
                    else
                        Map[i][j]='R';
                    sao(i,j,0);
                }
            }
        }
        for(int i=0; i<n; i++)
        {
            for(int j=0; j<m; j++)
            {
                if(vis[i][j])
                    continue;
                if(Map[i][j]=='.')
                    continue;
                sum++;
                if(Map[i][j]=='R'||Map[i][j]=='G')
                {
                    if(Map[i][j]=='R')
                        vis[i][j] = 1;
                    else
                        Map[i][j]='B';
                    sao(i,j,1);
                }
                else if(Map[i][j]=='B'||Map[i][j]=='G')
                {
                    if(Map[i][j]=='B')
                        vis[i][j] = 1;
                    else
                        Map[i][j]='R';
                    sao(i,j,0);
                }
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}



版权声明:本文为博主原创文章,未经博主允许不得转载。

HDU 5319多校 模拟

标签:多校   模拟   

原文地址:http://blog.csdn.net/u013588639/article/details/47112189

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!