码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1265 Area

时间:2014-07-09 12:53:50      阅读:179      评论:0      收藏:0      [点我收藏+]

标签:poj   acm   

Area
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 4713   Accepted: 2129

Description

Being well known for its highly innovative products, Merck would definitely be a good target for industrial espionage. To protect its brand-new research and development facility the company has installed the latest system of surveillance robots patrolling the area. These robots move along the walls of the facility and report suspicious observations to the central security office. The only flaw in the system a competitor抯 agent could find is the fact that the robots radio their movements unencrypted. Not being able to find out more, the agent wants to use that information to calculate the exact size of the area occupied by the new facility. It is public knowledge that all the corners of the building are situated on a rectangular grid and that only straight walls are used. Figure 1 shows the course of a robot around an example area. 

bubuko.com,布布扣 
Figure 1: Example area. 

You are hired to write a program that calculates the area occupied by the new facility from the movements of a robot along its walls. You can assume that this area is a polygon with corners on a rectangular grid. However, your boss insists that you use a formula he is so proud to have found somewhere. The formula relates the number I of grid points inside the polygon, the number E of grid points on the edges, and the total area A of the polygon. Unfortunately, you have lost the sheet on which he had written down that simple formula for you, so your first task is to find the formula yourself. 

Input

The first line contains the number of scenarios. 
For each scenario, you are given the number m, 3 <= m < 100, of movements of the robot in the first line. The following m lines contain pairs 揹x dy?of integers, separated by a single blank, satisfying .-100 <= dx, dy <= 100 and (dx, dy) != (0, 0). Such a pair means that the robot moves on to a grid point dx units to the right and dy units upwards on the grid (with respect to the current position). You can assume that the curve along which the robot moves is closed and that it does not intersect or even touch itself except for the start and end points. The robot moves anti-clockwise around the building, so the area to be calculated lies to the left of the curve. It is known in advance that the whole polygon would fit into a square on the grid with a side length of 100 units. 

Output

The output for every scenario begins with a line containing 揝cenario #i:? where i is the number of the scenario starting at 1. Then print a single line containing I, E, and A, the area A rounded to one digit after the decimal point. Separate the three numbers by two single blanks. Terminate the output for the scenario with a blank line.

Sample Input

2
4
1 0
0 1
-1 0
0 -1
7
5 0
1 3
-2 2
-1 0
0 -3
-3 1
0 -3

Sample Output

Scenario #1:
0 4 1.0

Scenario #2:
12 16 19.0


计算几何题,主要掌握多边形面积公式,路径点比较好算

内点由皮克定理可得,即内点=面积+路径点/2+1;


AC代码如下:


#include<iostream>
#include<cstring>
#include<cmath>
#include<cstdio>
using namespace std;

int n;
double dx[105],dy[105],x[105],y[105];
int step;

int ss(int a,int b)
{
    int r,t;
    if(a<b)
    {t=a;a=b;b=t;}
    while(b)
    {
        r=a%b;
        a=b;
        b=r;
    }
    return a;
}

void work1()
{
    int i,j;
    for(i=1;i<=n;i++)
    {
        if(dx[i]==0)
            step+=abs((int)dy[i]);
        else if(dy[i]==0)
            step+=abs((int)dx[i]);
        else
            step+=abs(ss((int)dx[i],(int)dy[i]));
        //cout<<step<<endl<<endl;
    }
}

int main()
{
    int t;
    int i,j,cas=0;
    cin>>t;
    while(t--)
    {
        cas++;
        cin>>n;
        x[0]=0;y[0]=0;step=0;
        for(i=1;i<=n;i++)
        {
            cin>>dx[i]>>dy[i];
            x[i]=x[i-1]+dx[i];
            y[i]=y[i-1]+dy[i];
        }
        work1();
        double sum=0;
        for(i=1;i<n;i++)
            sum+=0.5*(x[i]*y[i+1]-x[i+1]*y[i]);
        int nd;
        nd=int(sum+1)-step/2;
        printf("Scenario #%d:\n",cas);
        cout<<nd<<" "<<step<<" ";
        printf("%.1f\n\n",sum);

    }

    return 0;
}




POJ 1265 Area,布布扣,bubuko.com

POJ 1265 Area

标签:poj   acm   

原文地址:http://blog.csdn.net/hanhai768/article/details/37561071

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!