码迷,mamicode.com
首页 > 其他好文 > 详细

poj 1860 Currency Exchange

时间:2015-07-29 10:15:07      阅读:131      评论:0      收藏:0      [点我收藏+]

标签:

http://poj.org/problem?id=1860

Currency Exchange
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 22461   Accepted: 8115

Description

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency. 
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR. 
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real RAB, CAB, RBA and CBA - exchange rates and commissions when exchanging A to B and B to A respectively. 
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations. 

Input

The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=103
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10-2<=rate<=102, 0<=commission<=102
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 104

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input

3 2 1 20.00
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES

题目大意: 调换货币, 共有n种货币,m种调换方式,Nick拥有的货币种类为s,拥有货币的价值为w, 货币a换成b的润率为r手续费为c,问最终换回种类为s的货币时Nick能否获益

数据分析:
3 2 1 20.00//如上
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00//货币2换成货币3的润率为1.10手续费为1.00,货币3换成货币2的润率为1.1
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<vector>
#include<queue>
#include<stdlib.h>
#include<ctype.h>
#define INF 0x3f3f3f3f
#define max(a, b)(a > b ? a : b)
#define min(a, b)(a < b ? a : b)
#define N 110

using namespace std;

struct node
{
    int e;
    double r, c;
};

vector<node>G[N];
int n;
bool vis[N];
double w, dist[N];

void Init()
{
    int i;
    memset(vis, false, sizeof(vis));
    for(i = 1 ; i <= n ; i++)
    {
        G[i].clear();
        dist[i] = 0;
    }
}
int SPFA(int s)
{
    queue<node>Q;
    node p, pn;
    int i, len;
    p.e = s;
    dist[s] = w;
    Q.push(p);
    vis[s] = true;
    while(!Q.empty())
    {
        p = Q.front();
        Q.pop();
        vis[p.e] = false;
        len = G[p.e].size();
        for(i = 0 ; i < len ; i++)
        {
            pn = G[p.e][i];
            if(dist[pn.e] < (dist[p.e] - pn.c) * pn.r)
            {
                dist[pn.e] = (dist[p.e] - pn.c) * pn.r;

                if(!vis[pn.e])
                {
                    Q.push(pn);
                    vis[pn.e] = true;
                }
                if(dist[s] > w && pn.e == s)
                    return 1;
            }
        }
    }
    return -1;
}

int main()
{
    node p;
    int m, s, i, a, b;
    double r, c;
    while(scanf("%d%d%d%lf", &n, &m, &s, &w) != EOF)
    {
        Init();
        for(i = 1 ; i <= m ; i++)
        {
            scanf("%d%d", &a, &b);
            scanf("%lf%lf", &r, &c);
            p.e = b, p.r = r, p.c = c;
            G[a].push_back(p);
            scanf("%lf%lf", &r, &c);
            p.e = a, p.r = r, p.c = c;
            G[b].push_back(p);
        }
        if(SPFA(s) == 1)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}

 

0,手续费为1.00

poj 1860 Currency Exchange

标签:

原文地址:http://www.cnblogs.com/qq2424260747/p/4685141.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!