码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 5323 Solve this interesting problem dfs 搜索

时间:2015-07-29 15:55:25      阅读:106      评论:0      收藏:0      [点我收藏+]

标签:搜索

链接:http://acm.hdu.edu.cn/showproblem.php?pid=5323

Solve this interesting problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1470    Accepted Submission(s): 420


Problem Description
Have you learned something about segment tree? If not, don’t worry, I will explain it for you.
Segment Tree is a kind of binary tree, it can be defined as this:
- For each node u in Segment Tree, u has two values: Lu and Ru.
- If Lu=Ru, u is a leaf node. 
- If LuRu, u has two children x and y,with Lx=Lu,Rx=?Lu+Ru2?,Ly=?Lu+Ru2?+1,Ry=Ru.
Here is an example of segment tree to do range query of sum.
Given two integers L and R, Your task is to find the minimum non-negative n satisfy that: A Segment Tree with root node‘s value Lroot=0 and Rroot=ncontains a node u with Lu=L and Ru=R.
 

Input
The input consists of several test cases. 
Each test case contains two integers L and R, as described above.
0LR109
LR?L+12015
 

Output
For each test, output one line contains one integer. If there is no such n, just output -1.
 

Sample Input
6 7 10 13 10 11
 

Sample Output
7 -1 12


题意:告诉你一个线段树有 一个区间 l到r,如果有这个种线段树  问根节点  0-n,  n最小是多少。如果没有输出-1

做法:搜索剪枝,主要那个剪枝右边界比较难想 比较重要。


#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
#define inf 100000000000
typedef long long ll;
ll ans;

void dfs(ll l,ll r)
{
	if(l<0) return ;//越界
	if(l==0) {ans=min(ans,r); return;}//符合要求 取最小值
	if(l<(r-l+1)) return ;
	//l 这个区间 右边空余的长度,   r-l+1  是这个区间的长度
	//要对称,所以左边空白区间  必须是 这个区间的 某一倍数,可以相等,但是必须要大于等于 当前这个区间。
	//用于限制r的增长
	ll len=r-l+1;
	dfs(l-len,r);
	dfs(l-len-1,r);

	dfs(l,r+len);
	if(l!=r)
	dfs(l,r+len-1);
}
int main()
{
    ll l,r;
    while(scanf("%I64d%I64d",&l,&r)!=EOF){ 
		ans=inf;
		dfs(l,r);
		if(ans==inf)
			puts("-1"); 
		else
		printf("%I64d\n",ans);
	}
	return 0;
}









版权声明:本文为博主原创文章,未经博主允许不得转载。

hdu 5323 Solve this interesting problem dfs 搜索

标签:搜索

原文地址:http://blog.csdn.net/u013532224/article/details/47128477

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!