码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 多校

时间:2015-07-29 15:57:11      阅读:126      评论:0      收藏:0      [点我收藏+]

标签:acm   hdu   

Painter

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 739    Accepted Submission(s): 343


Problem Description
Mr. Hdu is an painter, as we all know, painters need ideas to innovate , one day, he got stuck in rut and the ideas dry up, he took out a drawing board and began to draw casually. Imagine the board is a rectangle, consists of several square grids. He drew diagonally, so there are two kinds of draws, one is like ‘\’ , the other is like ‘/’. In each draw he choose arbitrary number of grids to draw. He always drew the first kind in red color, and drew the other kind in blue color, when a grid is drew by both red and blue, it becomes green. A grid will never be drew by the same color more than one time. Now give you the ultimate state of the board, can you calculate the minimum time of draws to reach this state.
 

Input
The first line is an integer T describe the number of test cases.
Each test case begins with an integer number n describe the number of rows of the drawing board.
Then n lines of string consist of ‘R’ ‘B’ ‘G’ and ‘.’ of the same length. ‘.’ means the grid has not been drawn.
1<=n<=50
The number of column of the rectangle is also less than 50.
Output
Output an integer as described in the problem description.
 

Output
Output an integer as described in the problem description.
 

Sample Input
2 4 RR.B .RG. .BRR B..R 4 RRBB RGGB BGGR BBRR
 

Sample Output
3 6
 

Source
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:  5326 5325 5324 5323 5322 


#include<cstdio>
#include<cmath>
#include<stdlib.h>
#include<map>
#include<set>
#include<time.h>
#include<vector>
#include<queue>
#include<string>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
#define eps 1e-8
#define INF 0x3f3f3f3f
#define max(a,b) ((a)>(b)?(a):(b))
#define min(a,b) ((a)<(b)?(a):(b))
#define maxn 55

char s[maxn][maxn];
int n;

int main()
{
    int T;
    scanf("%d", &T);
    while(T--)
    {
        scanf("%d", &n);
        for(int i=1; i<=n; i++)
            scanf("%s", s[i] + 1);

        int m = strlen(s[1] + 1);

        int ans = 0;
        for(int i=1; i<=n; i++)
            for(int j=1; j<=m; j++)
                if(s[i][j] == 'R' || s[i][j] == 'G')
                    if(!(s[i-1][j-1] == 'R' || s[i-1][j-1] == 'G'))
                            ans++;

        for(int i=1; i<=n; i++)
            for(int j=1; j<=m; j++)
                if(s[i][j] == 'B' || s[i][j] == 'G')
                    if(!(s[i-1][j+1] == 'B' || s[i-1][j+1] == 'G'))
                            ans++;

        printf("%d\n", ans);
    }
    return 0;
}


 

版权声明:本文为博主原创文章,未经博主允许不得转载。

hdu 多校

标签:acm   hdu   

原文地址:http://blog.csdn.net/dojintian/article/details/47128387

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!