码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 5326 Work

时间:2015-07-29 17:23:11      阅读:104      评论:0      收藏:0      [点我收藏+]

标签:

Work

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 549    Accepted Submission(s): 375


Problem Description
技术分享


It’s an interesting experience to move from ICPC to work, end my college life and start a brand new journey in company.
As is known to all, every stuff in a company has a title, everyone except the boss has a direct leader, and all the relationship forms a tree. If A’s title is higher than B(A is the direct or indirect leader of B), we call it A manages B.
Now, give you the relation of a company, can you calculate how many people manage k people. 
 

Input
There are multiple test cases.
Each test case begins with two integers n and k, n indicates the number of stuff of the company.
Each of the following n-1 lines has two integers A and B, means A is the direct leader of B.

1 <= n <= 100 , 0 <= k < n
1 <= A, B <= n
 

Output
For each test case, output the answer as described above.
 

Sample Input
7 2 1 2 1 3 2 4 2 5 3 6 3 7
 

Sample Output
2
 

Source





#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
struct node
{
    int u;
    int v;
    int next;
}edge[100000];
int cnt;
int head[1000],vis[1000],sum[1000];
void add(int u,int v)
{
    edge[cnt].u=u;
    edge[cnt].v=v;
    edge[cnt].next=head[u];
    head[u]=cnt++;
}
void dfs(int u)
{
    vis[u]=1;
    for(int i=head[u];i!=-1;i=edge[i].next)
    {
        int v=edge[i].v;
        if(vis[v]==0)
        {
            sum[u]++;
            dfs(v);
            sum[u]+=sum[v];
        }
    }
}
int main()
{
    int n,k,i,a,b,v;
    while(scanf("%d%d",&n,&k)!=EOF)
    {
        cnt=0;
         memset(head,-1,sizeof(head));
        for(i=1;i<=n-1;i++)
        {
          scanf("%d%d",&a,&b);
          add(a,b);
        }
         memset(sum,0,sizeof(sum));
         memset(vis,0,sizeof(vis));
        for(i=1;i<=n;i++)
        {
            if(vis[i]==0)
            {
                dfs(i);
            }
        }
        v=0;
        for(i=1;i<=n;i++)
        {
            if(sum[i]==k)
            {
               v++;
            }
        }
        printf("%d\n",v);
    }
    return 0;
}


 

版权声明:本文为博主原创文章,如有特殊需要请与博主联系 QQ : 793977586。

HDU 5326 Work

标签:

原文地址:http://blog.csdn.net/yeguxin/article/details/47129109

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!