标签:
Time Limit: 10 Sec Memory Limit: 162 MB
Submit: 1991 Solved: 1185
Description
在N×N的棋盘里面放K个国王,使他们互不攻击,共有多少种摆放方案。国王能攻击到它上下左右,以及左上左下右上右下八个方向上附近的各一个格子,共8个格子。
Input
只有一行,包含两个数N,K ( 1 <=N <=9, 0 <= K <= N * N)
Output
方案数。
Sample Input
3 2
Sample Output
16
HINT
Source
题解:
状压dp,设f[i][j][k]表示前i行一共放了j个,第i行的状态是k(k是对这一行压出来的二进制数)。
转移:
Code:
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
int N,K,all;
long long ans,f[20][100][520];
int count(int x){
int s=0;
for (int i=x; i>0; i>>=1)
if (i&1) s++;
return s;
}
void dp(){
all=(1<<N)-1; ans=0;
memset(f,0,sizeof(f));
for (int i=0; i<=all; i++)
if (!(i&(i<<1)) && !(i&(i>>1)))
f[1][count(i)][i]=1;
for (int i=2; i<=N; i++)
for (int j=0; j<=K; j++)
for (int k=0; k<=all; k++)
if (!(k&(k<<1)) && !(k&(k>>1))){
int tot=count(k);
if (j<tot) continue;
for (int s=0; s<=all; s++)
if (!(s&(s<<1)) && !(s&(s>>1)) && !(s&k) && !(s&(k<<1)) && !(s&(k>>1)))
f[i][j][k]+=f[i-1][j-tot][s];
}
for (int i=0; i<=all; i++)
if (!(i&(i<<1)) && !(i&(i>>1)))
ans+=f[N][K][i];
}
int main(){
scanf("%d%d",&N,&K);
dp(); printf("%lld\n",ans);
return 0;
}
版权声明:本文为博主原创文章,未经博主允许不得转载。
【状压dp】【bzoj 1087】【SCOI 2005】互不侵犯King
标签:
原文地址:http://blog.csdn.net/morestep/article/details/47130581