码迷,mamicode.com
首页 > 其他好文 > 详细

zoj 3735 概率dp

时间:2015-07-29 21:10:39      阅读:109      评论:0      收藏:0      [点我收藏+]

标签:

Josephina and RPG

Time Limit: 2 Seconds      Memory Limit: 65536 KB      Special Judge

A role-playing game (RPG and sometimes roleplaying game) is a game in which players assume the roles of characters in a fictional setting. Players take responsibility for acting out these roles within a narrative, either through literal acting or through a process of structured decision-making or character development.

Recently, Josephina is busy playing a RPG named TX3. In this game, M characters are available to by selected by players. In the whole game, Josephina is most interested in the "Challenge Game" part.

The Challenge Game is a team play game. A challenger team is made up of three players, and the three characters used by players in the team are required to be different. At the beginning of the Challenge Game, the players can choose any characters combination as the start team. Then, they will fight with N AI teams one after another. There is a special rule in the Challenge Game: once the challenger team beat an AI team, they have a chance to change the current characters combination with the AI team. Anyway, the challenger team can insist on using the current team and ignore the exchange opportunity. Note that the players can only change the characters combination to the latest defeated AI team. The challenger team get victory only if they beat all the AI teams.

Josephina is good at statistics, and she writes a table to record the winning rate between all different character combinations. She wants to know the maximum winning probability if she always chooses best strategy in the game. Can you help her?

技术分享

Input

There are multiple test cases. The first line of each test case is an integer M (3 ≤ M ≤ 10), which indicates the number of characters. The following is a matrix T whose size is R × R.R equals to C(M, 3). T(i, j) indicates the winning rate of team i when it is faced with team j. We guarantee that T(i, j) + T(j, i) = 1.0. All winning rates will retain two decimal places. An integer N (1 ≤ N ≤ 10000) is given next, which indicates the number of AI teams. The following line contains N integers which are the IDs (0-based) of the AI teams. The IDs can be duplicated.

Output

For each test case, please output the maximum winning probability if Josephina uses the best strategy in the game. For each answer, an absolute error not more than 1e-6 is acceptable.

Sample Input

4 0.50 0.50 0.20 0.30 0.50 0.50 0.90 0.40 0.80 0.10 0.50 0.60 0.70 0.60 0.40 0.50 3 0 1 2

Sample Output

0.378000

 

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=3735

思路:设dp[i][j]表示打【第i个敌人时用第j种队伍的最大胜率】,那么状态转移有两种,设p[x][y]表示第x种队伍对第y种队伍的胜率,设第i个AI是队伍k。那么我们有:
for(j : 1 - m) dp[0][j] = 1.0;
for(i : 1 - n)
   for(j : 1 - m)
      dp[i][j]=p[j][k] * max(dp[i+1][j],dp[i+1][k]);
第一种表示不换,第二种表示换。最后for循环求dp[1][j]的最大值即可。

AC代码:

 1 #include <iostream>
 2 #include <cstdio>
 3 #include <cstring>
 4 using namespace std;
 5 int m, n;
 6 int AI[10010];
 7 double beat[150][150], dp[10010][150];
 8 int main(){
 9     while(~scanf("%d", &m)){
10         memset(AI, 0sizeof(AI));
11         memset(dp, 0.0sizeof(dp));
12         m = m * (m - 1) * (m - 2) / 6;
13         for(int i = 0; i < m; i++){
14             for(int j = 0; j < m; j++){
15                 scanf("%lf", &beat[i][j]);
16             }
17         }
18         scanf("%d", &n);
19         for(int i = n; i > 0; i--)
20             scanf("%d", &AI[i]);
21         for(int i = 0; i < 150; i++){
22             dp[0][i] = 1.0;
23         }
24         for(int i = 1; i <= n; i++){
25             for(int j = 0; j < m; j++){
26                 if(dp[i - 1][j] > dp[i - 1][AI[i]])
27                     dp[i][j] = beat[j][AI[i]] * dp[i - 1][j];
28                 else
29                     dp[i][j] = beat[j][AI[i]] * dp[i - 1][AI[i]];
30             }
31         }
32         double ans = -1.0;
33         for(int i = 0; i < m; i++){
34             if(ans < dp[n][i])
35                 ans = dp[n][i];
36         }
37         printf("%lf\n", ans);
38     }
39     return 0;

40 } 

zoj 3735 概率dp

标签:

原文地址:http://www.cnblogs.com/gaoxiang36999/p/4687217.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!