码迷,mamicode.com
首页 > 其他好文 > 详细

hdoj-1159-Common Subsequence【动态规划求最长公共子序列】

时间:2015-07-29 21:23:45      阅读:121      评论:0      收藏:0      [点我收藏+]

标签:

Common Subsequence

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 28152 Accepted Submission(s): 12556


Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input
abcfbc abfcab programming contest abcd mnp

Sample Output
4 2 0

Source

Recommend
Ignatius | We have carefully selected several similar problems for you: 1087 1058 1069 1421 1160

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
char s1[1000],s2[1000];
int c[1001][1001];
int main(){
	while(~scanf("%s%s",s1,s2)){
		int len1=strlen(s1),len2=strlen(s2);
		memset(c,0,sizeof(c));
		for(int i=0;i<len1;++i){
			for(int j=0;j<len2;++j){
				if(s1[i]==s2[j]){
					c[i+1][j+1]=c[i][j]+1;
				}
				else c[i+1][j+1]=max(c[i][j+1],c[i+1][j]);
			}
		}
		printf("%d\n",c[len1][len2]);
	}
	return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

hdoj-1159-Common Subsequence【动态规划求最长公共子序列】

标签:

原文地址:http://blog.csdn.net/qq_18062811/article/details/47133363

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!