码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1213 How Many Tables

时间:2015-07-29 21:26:28      阅读:115      评论:0      收藏:0      [点我收藏+]

标签:

How Many Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 18146    Accepted Submission(s): 8936


Problem Description
Today is Ignatius‘ birthday. He invites a lot of friends. Now it‘s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
 

Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
 

Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
 

Sample Input
2 5 3 1 2 2 3 4 5 5 1 2 5
 

Sample Output
2 4
 

Author
Ignatius.L
 

Source
 

思路:

            这是考察并查集的一道题。首先输入一个数代表测试案例的个数,然后输入n和m分别代表亲戚的总数和关系的总数,后面跟上m行,每行输入两个数,说明这两个数之间有关系,也就是这两个数的根相同,通过并查集的方法看看有多少个树根就有多少桌,具体做法看代码:

 

代码:

 

#include <stdio.h>
#define max 1005
int pre[max];
int n,m;

void init()
{
	for(int i=1;i<=n;i++)
    	pre[i]=i;
}

int find(int x)
{
	int r=x;
	while(r!=pre[r])
		r=pre[r];
	int i,j;
	i=x;
	while(i!=r)
	{
		j=pre[i];
		pre[i]=r;
		i=j;
	}	
	return r;
}

void jion(int x,int y)
{
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy)
	  pre[fx]=fy;	
}

int main()
{
	int a,b;
	int N;
	scanf("%d",&N);
	while(N--)
	{
		scanf("%d%d",&n,&m);
		init();
		for(int i=1;i<=m;i++)
		{
			scanf("%d%d",&a,&b);
			jion(a,b);
		}
		int s=0;
		for(int i=1;i<=n;i++)
		{
			if(i==pre[i])
		      s++;
		}
		printf("%d\n",s);
	}
	return 0;
} 


 

 

 
 

版权声明:本文为博主原创文章,未经博主允许不得转载。

HDU 1213 How Many Tables

标签:

原文地址:http://blog.csdn.net/dxx_111/article/details/47133071

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!