码迷,mamicode.com
首页 > 其他好文 > 详细

hdoj 2120 Ice_cream's world I

时间:2015-07-29 21:30:11      阅读:125      评论:0      收藏:0      [点我收藏+]

标签:

Ice_cream‘s world I

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 814    Accepted Submission(s): 478


Problem Description
ice_cream‘s world is a rich country, it has many fertile lands. Today, the queen of ice_cream wants award land to diligent ACMers. So there are some watchtowers are set up, and wall between watchtowers be build, in order to partition the ice_cream’s world. But how many ACMers at most can be awarded by the queen is a big problem. One wall-surrounded land must be given to only one ACMer and no walls are crossed, if you can help the queen solve this problem, you will be get a land.
 

Input
In the case, first two integers N, M (N<=1000, M<=10000) is represent the number of watchtower and the number of wall. The watchtower numbered from 0 to N-1. Next following M lines, every line contain two integers A, B mean between A and B has a wall(A and B are distinct). Terminate by end of file.
 

Output
Output the maximum number of ACMers who will be awarded.
One answer one line.
 

Sample Input
8 10 0 1 1 2 1 3 2 4 3 4 0 5 5 6 6 7 3 6 4 7
 

Sample Output
3
 


思路:求环的个数。输入数据有多组。

 

 

代码:

 

#include<stdio.h>
#include<stdlib.h>
#include<algorithm>
#include<queue>
using namespace std;
int per[1100];
int n,m,f;
int init()
{
	for(int i=0;i<n;i++)
	{
		per[i]=i;
	}
}
int find(int x)
{
	int r;
	r=x;
	while(r!=per[r])
	{
		r=per[r];
	}
	per[x]=r;
	return r;
}
int join(int x,int y)
{
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy)
	per[fx]=fy;
	else
	f++;
}
int main()
{
	int a,b,i;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		f=0;
	    init();
	    for(i=0;i<m;i++)
	    {
	    	scanf("%d%d",&a,&b);
	    	join(a,b);
    	}
    	printf("%d\n",f);
	}
	return 0;
}


 

版权声明:本文为博主原创文章,未经博主允许不得转载。

hdoj 2120 Ice_cream's world I

标签:

原文地址:http://blog.csdn.net/longge33445/article/details/47132351

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!