码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 5326

时间:2015-07-29 23:02:00      阅读:121      评论:0      收藏:0      [点我收藏+]

标签:

Work

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 618    Accepted Submission(s): 412

Problem Description
It’s an interesting experience to move from ICPC to work, end my college life and start a brand new journey in company.
As is known to all, every stuff in a company has a title, everyone except the boss has a direct leader, and all the relationship forms a tree. If A’s title is higher than B(A is the direct or indirect leader of B), we call it A manages B.
Now, give you the relation of a company, can you calculate how many people manage k people. 
 
Input
There are multiple test cases.
Each test case begins with two integers n and k, n indicates the number of stuff of the company.
Each of the following n-1 lines has two integers A and B, means A is the direct leader of B.
1 <= n <= 100 , 0 <= k < n
1 <= A, B <= n
 
Output
For each test case, output the answer as described above.
 
Sample Input
7 2
1 2
1 3
2 4
2 5
3 6
3 7
 
Sample Output

2

//这题是要求管理了m个人的有多少个

//利用pre[]数组 记录每个b的pre[b]为a; 接着从b到根的中的人掌控的个数+1 例如 

3 2   1  2    2  3   pre[2]=1; c[1]++ pre[3]=2; c[2]++-> pre[2]=1 c[1]++; 所以掌握个数为2的有一个c[1] 

#include <stdio.h>
#include <string.h>
int pre[110];
int c[110];


int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        memset(c,0,sizeof(c));
        for(int i=0;i<=n;i++)
            pre[i]=i;
        int a,b;
        for(int i=0;i<n-1;i++)
        {
            scanf("%d%d",&a,&b);
            pre[b]=a;
            while(pre[b]!=b)  //从b到根 每个上级掌控人数加1;
            {
                b=pre[b];
                c[b]++;
            }
        }
        int cnt=0;
        for(int i=1;i<=n;i++)
        {
            if(c[i]==m)
                cnt++;
        }
        printf("%d\n",cnt);
    }
    return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

hdu 5326

标签:

原文地址:http://blog.csdn.net/a73265/article/details/47135043

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!