码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1003

时间:2015-07-30 00:21:12      阅读:111      评论:0      收藏:0      [点我收藏+]

标签:

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 177224    Accepted Submission(s): 41322


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

 

Sample Input
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

 

Sample Output
Case 1: 14 1 4 Case 2: 7 1 6
 
题意:给你一串数字,求连续子串的最大和,并记录子串的起始位置和终止位置
分析:用start记录起始位置,用end记录终止位置。设置一个sum记录子串和,如果子串和小于0,sum=0,从头开始记录,其中sum会有一个最大值,用ans记录那个最大值,输出最大和ans和起始位置start及末尾位置end
#include<iostream>
#include<cstdio>
using namespace std;
int a[100005];
int main(){
    int t,n,ans,count=1;
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        int flag=0,max=-1001,tem;
        for(int i=0;i<n;i++){
            scanf("%d",&a[i]);
            if(a[i]>=0) flag=1;/*记录串是否有大于0的数*/
            if(a[i]>max){ max=a[i];tem=i;}/*记录串中最大的数的大小及位置*/
        }
        if(!flag) printf("Case %d:\n%d %d %d\n",count++,max,tem+1,tem+1);/*如果串全部小于0,输出最大的数的大小及位置*/
        else{
            int start=0,end=0,sum,temp=0;/*temp记录sum=0的位置,如果找到比ans大的sum,将temp赋值给start*/
            ans=a[0];sum=a[0];
            for(int i=1;i<n;i++){
                if(sum<0){
                    temp=i;
                    sum=0;
                }
                sum+=a[i];
                if(ans<sum){
                    ans=sum;
                    start=temp;
                    end=i;
                }
            }
            printf("Case %d:\n%d %d %d\n",count++,ans,start+1,end+1);
        }
        if(t) printf("\n");
    }
    return 0;
}

 

hdu 1003

标签:

原文地址:http://www.cnblogs.com/wabi87547568/p/4687774.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!