码迷,mamicode.com
首页 > 其他好文 > 详细

ACM寻找连续的数的乘积最大值

时间:2015-07-30 10:59:44      阅读:146      评论:0      收藏:0      [点我收藏+]

标签:

Given a sequence of integers S = {S1, S2, . . . , Sn}, you should determine what is the value of the maximum positive product involving consecutive terms of S. If you cannot find a positive sequence, you should consider 0 as the value of the maximum product.

Input

Each test case starts with 1 ≤ N ≤ 18, the number of elements in a sequence. Each element Si is an integer such that −10 ≤ Si ≤ 10. Next line will have N integers, representing the value of each element in the sequence. There is a blank line after each test case. The input is terminated by end of file (EOF).

Output

For each test case you must print the message: ‘Case #M: The maximum product is P.’, where M is the number of the test case, starting from 1, and P is the value of the maximum product. After each test case you must print a blank line.

Sample Input 3 2 4 -3 5 2 5 -1 2 -1

Sample Output

Case #1:The maximum product is 8.

Case #2: The maximum product is 20.

解题思路:这个题目的大意是让我们寻找连续的数的乘积的最大值。我们用两个for循环就解决掉了这两个问题,然后比较得出最大的乘积数。

程序代码:

#include <iostream>
using namespace std;
int a[22];
int main()
{
    int n,v=0;
    long t;
    while(cin>>n&&n)
    {
        v++;
        long min=0;
        for(int i=0;i<n;i++)
            cin>>a[i];
        for(int k=0;k<n;k++)
        {
            t=1;
            for(int j=k;j<n;j++)
            {
                t=t*a[j];
                if(t>min)
                    min=t;
            }
        }
        cout<<"Case #"<<v<<": The maximum product is "<<min<<"."<<endl<<endl;

    }
    return 0;

}

 

ACM寻找连续的数的乘积最大值

标签:

原文地址:http://www.cnblogs.com/xinxiangqing/p/4688350.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!