码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 2199~Can you solve the equation?~二分法求解

时间:2015-07-30 13:38:39      阅读:104      评论:0      收藏:0      [点我收藏+]

标签:c++   hdu   二分法   水题   

Can you solve this equation?

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 28   Accepted Submission(s) : 17
Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
 

Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
 

Sample Input
2 100 -4
 

Sample Output
1.6152 No solution!
 
 
AC_code:
#include<stdio.h>
#include<math.h>
double f(double x)
{
	return 8*x*x*x*x+ 7*x*x*x + 2*x*x + 3*x + 6; 
}
int main()
{
	int n;
	double y,mid,l,r;
	scanf("%d",&n);
	while(n--)
	{
		scanf("%lf",&y);
		if(y<f(0)||y>f(100))
			printf("No solution!\n");
		else
		{
			l=0;r=100;
			while(r-l>1e-10)
			{
				mid=(r+l)/2;
				 if(f(mid)<y)
					l=mid+1e-10;
				else
					r=mid-1e-10;
			}
			printf("%.4lf\n",mid);
		}
	}
	return 0;
}

 
 
 
 
 
 
 
 
 

版权声明:本文为博主原创文章,未经博主允许不得转载。

hdu 2199~Can you solve the equation?~二分法求解

标签:c++   hdu   二分法   水题   

原文地址:http://blog.csdn.net/lin14543/article/details/47147575

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!