码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ Hard Disk Drive 4788【2013成都区域赛H题-水】

时间:2015-07-30 13:42:08      阅读:140      评论:0      收藏:0      [点我收藏+]

标签:

Hard Disk Drive

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1887    Accepted Submission(s): 1042


Problem Description
  Yesterday your dear cousin Coach Pang gave you a new 100MB hard disk drive (HDD) as a gift because you will get married next year.
  But you turned on your computer and the operating system (OS) told you the HDD is about 95MB. The 5MB of space is missing. It is known that the HDD manufacturers have a different capacity measurement. The manufacturers think 1 “kilo” is 1000 but the OS thinks that is 1024. There are several descriptions of the size of an HDD. They are byte, kilobyte, megabyte, gigabyte, terabyte, petabyte, exabyte, zetabyte and yottabyte. Each one equals a “kilo” of the previous one. For example 1 gigabyte is 1 “kilo” megabytes.
  Now you know the size of a hard disk represented by manufacturers and you want to calculate the percentage of the “missing part”.
 

Input
  The first line contains an integer T, which indicates the number of test cases.
  For each test case, there is one line contains a string in format “number[unit]” where number is a positive integer within [1, 1000] and unit is the description of size which could be “B”, “KB”, “MB”, “GB”, “TB”, “PB”, “EB”, “ZB”, “YB” in short respectively.
 

Output
  For each test case, output one line “Case #x: y”, where x is the case number (starting from 1) and y is the percentage of the “missing part”. The answer should be rounded to two digits after the decimal point.
 

Sample Input
2 100[MB] 1[B]
 

Sample Output
Case #1: 4.63% Case #2: 0.00%
Hint
技术分享
 

Source
 

Recommend
We have carefully selected several similar problems for you:  5326 5325 5324 5323 5322 
 

水~

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>

using namespace std;

int main()
{
	int t;
	scanf("%d",&t);
	int xp=1;
	while(t--){
		double x=0;
		char s[10];
		scanf("%s",s);
		int l=strlen(s);
		char str[5];
		int i;
		for(i=0;;i++){
			if(s[i]=='[')break;
			x=x*10+(s[i]-'0');
		}
		int k=0;
		for(int j=i+1;j<l-1;j++){
			str[k++]=s[j];
		}
		str[k]='\0';
		double sum=x;
		int xn,dn;
		if(str[0]=='B'){
			sum=x;
		}
		else if(str[0]=='K'){
			sum=sum*1000.0/1024.0;
		}
		else if(str[0]=='M'){
				dn=xn=2;
			while(xn--){
				sum*=1000.0;
			}
			while(dn--){
				sum/=1024.0;
			}
		}
		else if(str[0]=='G'){
			dn=xn=3;
			while(xn--){
				sum*=1000.0;
			}
			while(dn--){
				sum/=1024.0;
			}
		}
		else if(str[0]=='T'){
			dn=xn=4;
			while(xn--){
				sum*=1000.0;
			}
			while(dn--){
				sum/=1024.0;
			}
		}
		else if(str[0]=='P'){
			dn=xn=5;
			while(xn--){
				sum*=1000.0;
			}
			while(dn--){
				sum/=1024.0;
			}
		}
		else if(str[0]=='E'){
			dn=xn=6;
			while(xn--){
				sum*=1000.0;
			}
			while(dn--){
				sum/=1024.0;
			}
		}
		else if(str[0]=='Z'){
			dn=xn=7;
			while(xn--){
				sum*=1000.0;
			}
			while(dn--){
				sum/=1024.0;
			}
		}
		else if(str[0]=='Y'){
			dn=xn=8;
			while(xn--){
				sum*=1000.0;
			}
			while(dn--){
				sum/=1024.0;
			}
		}
		double res=(x-sum)*100.0/x;
		printf("Case #%d: %.2lf%%\n",xp++,res);
	}
    return 0;
}



版权声明:本文为博主原创文章,转载请注明出处。

HDOJ Hard Disk Drive 4788【2013成都区域赛H题-水】

标签:

原文地址:http://blog.csdn.net/ydd97/article/details/47146805

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!