码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 4788 Hard Disk Drive

时间:2015-07-30 17:00:26      阅读:159      评论:0      收藏:0      [点我收藏+]

标签:

Hard Disk Drive

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1901    Accepted Submission(s): 1047


Problem Description
  Yesterday your dear cousin Coach Pang gave you a new 100MB hard disk drive (HDD) as a gift because you will get married next year.
  But you turned on your computer and the operating system (OS) told you the HDD is about 95MB. The 5MB of space is missing. It is known that the HDD manufacturers have a different capacity measurement. The manufacturers think 1 “kilo” is 1000 but the OS thinks that is 1024. There are several descriptions of the size of an HDD. They are byte, kilobyte, megabyte, gigabyte, terabyte, petabyte, exabyte, zetabyte and yottabyte. Each one equals a “kilo” of the previous one. For example 1 gigabyte is 1 “kilo” megabytes.
  Now you know the size of a hard disk represented by manufacturers and you want to calculate the percentage of the “missing part”.
 

Input
  The first line contains an integer T, which indicates the number of test cases.
  For each test case, there is one line contains a string in format “number[unit]” where number is a positive integer within [1, 1000] and unit is the description of size which could be “B”, “KB”, “MB”, “GB”, “TB”, “PB”, “EB”, “ZB”, “YB” in short respectively.
 

Output
  For each test case, output one line “Case #x: y”, where x is the case number (starting from 1) and y is the percentage of the “missing part”. The answer should be rounded to two digits after the decimal point.
 

Sample Input
2 100[MB] 1[B]
 

Sample Output
Case #1: 4.63% Case #2: 0.00%
Hint

技术分享

#include<stdio.h>
#include<math.h>
#include<string.h>
char ch[10][7]={"[B]","[KB]","[MB]","[GB]","[TB]","[PB]","[EB]","[ZB]","[YB]"};
char s[5];
int main()
{
	int t,v=1,i,j;
	int a;
	scanf("%d",&t);
	while(t--){
		scanf("%d%s",&a,s);//a的大小对结果没有影响 
		for(i=0;i<10;i++){
			if(strcmp(ch[i],s)==0)
				break;
		}
		double r=1-pow(1000.0,i)/pow(1024.0,i);
		printf("Case #%d: %.2lf%%\n",v++,r*100);
	}
	return 0;
 } 


hdu 4788 Hard Disk Drive

标签:

原文地址:http://blog.csdn.net/ling_du/article/details/47151573

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!