码迷,mamicode.com
首页 > 其他好文 > 详细

Can you solve this equation?

时间:2015-07-30 17:14:01      阅读:88      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 12908    Accepted Submission(s): 5774


Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
 

Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
 

Sample Input
2 100 -4
 

Sample Output
1.6152 No solution!
#include<stdio.h>
double m;
double f(double x)
{
	return 8*x*x*x*x+7*x*x*x+2*x*x+3*x+6;
}
int main()
{
	int n;
	scanf("%d",&n);
	while(n--)
	{
		
		double l,r,s,h;
		scanf("%lf",&m);
		if(f(0)<=m&&f(100)>=m)
		{
			l=0,r=100;
			while(r-l>1e-7)
			{
				h=(r+l)/2;
				s=f(h);
				if(s>m)
				r=h;
				else
				l=h;
			}
			printf("%.4lf\n",(r+l)/2);
		}
		else printf("No solution!\n");
	}
		return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

Can you solve this equation?

标签:

原文地址:http://blog.csdn.net/l15738519366/article/details/47150239

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!