码迷,mamicode.com
首页 > 其他好文 > 详细

HDU-5327 Olympiad

时间:2015-07-30 21:21:49      阅读:94      评论:0      收藏:0      [点我收藏+]

标签:

http://acm.hdu.edu.cn/showproblem.php?pid=5327

 

Olympiad

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 182    Accepted Submission(s): 130

Problem Description
You are one of the competitors of the Olympiad in numbers. The problem of this year relates to beatiful numbers. One integer is called beautiful if and only if all of its digitals are different (i.e. 12345 is beautiful, 11 is not beautiful and 100 is not beautiful). Every time you are asked to count how many beautiful numbers there are in the interval [a,b] (ab)技术分享
. Please be fast to get the gold medal!
 
Input
The first line of the input is a single integer T (T1000)技术分享
, indicating the number of testcases.
For each test case, there are two numbers a技术分享
and b技术分享
, as described in the statement. It is guaranteed that 1ab100000技术分享
.
 
Output
For each testcase, print one line indicating the answer.
 
Sample Input
2
1 10
1 1000
 
Sample Output
10
738
#include<iostream>
#include<cstdio>
using namespace std;
int a[100000];
int g(int n)
{
     int a[10],r=0,q,i,flag=0;;
    while(n)
    {
        q=n%10;
        a[r++]=q;
        for(i=0;i<r-1;i++)
        {
            if(q==a[i])
                flag=1;
        }
        n=n/10;
        if(flag==1)
            break;
    }
     if(flag==0)
         return 0;
     else
       return 1;

}
void fun()
{
    int i;
    a[0]=0;
    for(i=1;i<=100000;i++)
    {
        if(g(i)==0)
           a[i]=a[i-1]+1;
        else
          a[i]=a[i-1];

    }
}
 int main()
 {
     fun();
     int t,n,m;
     scanf("%d",&t);
     while(t--)
     {

         scanf("%d%d",&n,&m);
         if(a[n]>a[n-1])
           printf("%d\n",a[m]-a[n]+1);
        else
           printf("%d\n",a[m]-a[n]);

     }
     return 0;

 }

 

 

HDU-5327 Olympiad

标签:

原文地址:http://www.cnblogs.com/cancangood/p/4690493.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!