码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ Ice_cream's world I 2120【并查集判断成环】

时间:2015-07-30 21:25:19      阅读:142      评论:0      收藏:0      [点我收藏+]

标签:

Ice_cream‘s world I

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 848    Accepted Submission(s): 494


Problem Description
ice_cream‘s world is a rich country, it has many fertile lands. Today, the queen of ice_cream wants award land to diligent ACMers. So there are some watchtowers are set up, and wall between watchtowers be build, in order to partition the ice_cream’s world. But how many ACMers at most can be awarded by the queen is a big problem. One wall-surrounded land must be given to only one ACMer and no walls are crossed, if you can help the queen solve this problem, you will be get a land.
 

Input
In the case, first two integers N, M (N<=1000, M<=10000) is represent the number of watchtower and the number of wall. The watchtower numbered from 0 to N-1. Next following M lines, every line contain two integers A, B mean between A and B has a wall(A and B are distinct). Terminate by end of file.
 

Output
Output the maximum number of ACMers who will be awarded.
One answer one line.
 

Sample Input
8 10 0 1 1 2 1 3 2 4 3 4 0 5 5 6 6 7 3 6 4 7
 

Sample Output
3
 

Author
Wiskey
 

Source
 

Recommend
威士忌   |   We have carefully selected several similar problems for you:  2122 2118 2119 2121 2117

题意:判断有几个环

并查集判断成环

判断父节点是否相同 如果不同就有环 

#include <iostream>
#include <stdio.h>
#include <algorithm>

using namespace std;

int r[1010];
int flag;
int find_x(int x)
{
	while(x!=r[x])
		x=r[x];
	return x;
}

void fun(int x,int y)
{
	x=find_x(x);
	y=find_x(y);
	if(x!=y){
		r[y]=x;
	}
	else flag++;
}
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF){
		for(int i=0;i<=n;i++)
			r[i]=i;
		flag=0;
		int a,b;
		for(int i=0;i<m;i++){
			scanf("%d%d",&a,&b);
			fun(a,b);
		}
		printf("%d\n",flag);
    }
    return 0;
}


版权声明:本文为博主原创文章,转载请注明出处。

HDOJ Ice_cream's world I 2120【并查集判断成环】

标签:

原文地址:http://blog.csdn.net/ydd97/article/details/47156193

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!