码迷,mamicode.com
首页 > 其他好文 > 详细

Can you find it?

时间:2015-07-30 21:33:10      阅读:144      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit: 10000/3000 MS (Java/Others)    Memory Limit: 32768/10000 K (Java/Others)

Total Submission(s): 17266    Accepted Submission(s): 4373


Problem Description
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
 

Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
 

Output
For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".
 

Sample Input
3 3 3 1 2 3 1 2 3 1 2 3 3 1 4 10
 

Sample Output
Case 1: NO YES NO
 


#include<stdio.h>
#include<algorithm>
using namespace std;
int s[300000];
int x[3][600];
int find(int *s,int e,int r,int y)
{
	int mid;
	while(e<=r)
	{
	    mid=(e+r)/2;
		if(y==s[mid])
		return 1;
	  else if(y<s[mid])
	    r=mid-1;
		else if(y>s[mid])
		e=mid+1;
	}
	return 0;
}
int main()
{
	int i,j,k,a,b,c,n;
	int f=0;
	while(scanf("%d%d%d",&a,&b,&c)!=EOF)
	{
		for(i=0;i<a;i++)
		scanf("%d",&x[0][i]);
		for(i=0;i<b;i++)
		scanf("%d",&x[1][i]);
		for(i=0;i<a;i++)
			for(j=0;j<b;j++)
				s[i*b+j]=x[0][i]+x[1][j];
		for(i=0;i<c;i++)
		scanf("%d",&x[2][i]);
		scanf("%d",&n);
		sort(s,s+a*b);
		printf("Case %d:\n",++f);
		while(n--)
		{
			int m;
			scanf("%d",&m);
			int p=0,t;
			for(i=0;i<c;i++)
			{
				t=m-x[2][i];
				p=find(s,0,a*b,t);
				if(p)
				break;
			}
			if(p)
			printf("YES\n");
			else printf("NO\n");
		}
	}
	return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

Can you find it?

标签:

原文地址:http://blog.csdn.net/l15738519366/article/details/47154837

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!