码迷,mamicode.com
首页 > 其他好文 > 详细

uva 572

时间:2015-07-30 23:30:30      阅读:140      评论:0      收藏:0      [点我收藏+]

标签:

Oil Deposits

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil.

A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

 

Input 

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 技术分享 and 技术分享. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*‘, representing the absence of oil, or `@‘, representing an oil pocket.

 

Output 

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

 

Sample Input 

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

 

Sample Output 

0
1
2
2
题意:
*代表没油的地方,@代表有油的地方,问你@连成一块的油田有多少块。
思路:
用dfs进行搜素,注意边界,此题跟poj2386基本一样。
代码:
#include<cstdio>
using namespace std;
const int maxn=105;
int N,M;
char field[maxn][maxn];
void dfs(int x,int y)
{
    field[x][y]='*';
    for(int dx=-1; dx<=1; dx++)
    {

        for(int dy=-1; dy<=1; dy++)
        {
            int nx=x+dx,ny=y+dy;
            if(nx>=0&&nx<N&&ny>=0&&ny<M&&field[nx][ny]=='@')
                dfs(nx,ny);


        }
    }
    return ;
}
int main()
{

   while (scanf("%d%d",&N,&M)&&N&&M)

{
     int sum=0;
    for(int i=0; i<N; i++)
            scanf("%s",&field[i]);//不能用scanf("%s",&field[i][j]),scanf会读回车,会乱了
    for(int i=0; i<N; i++)
    {
        for(int j=0; j<M; j++)
            if(field[i][j]=='@')
            {
                dfs(i,j);
                sum++;
            }
    }
    printf("%d\n",sum);



}


return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

uva 572

标签:

原文地址:http://blog.csdn.net/a1967919189/article/details/47156477

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!