码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 2141~ ??Can you find it? 还是二分法~~??????

时间:2015-07-30 23:32:13      阅读:156      评论:0      收藏:0      [点我收藏+]

标签:hdu   二分法   

Can you find it?

Time Limit : 10000/3000ms (Java/Other)   Memory Limit : 32768/10000K (Java/Other)
Total Submission(s) : 274   Accepted Submission(s) : 87
Problem Description
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
 

Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
 

Output
For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".
 

Sample Input
3 3 3 1 2 3 1 2 3 1 2 3 3 1 4 10
 

纳闷儿的是我注释掉的明明可以减轻程序运行的负担~但实际上确实Wrong answer~注释掉就ac了~~~技术分享

AC-code:

Sample Output
Case 1: NO YES NO
#include<stdio.h>
#include<algorithm>
using namespace std;
int A[505],B[505],C[505],num[500*500*500+10];
int main()
{
	int l,m,n,i,j,le,k,r,x,s,mid,p=1;
	while(~scanf("%d%d%d",&l,&m,&n))
	{
		for(i=0;i<l;i++)
			scanf("%d",&A[i]);
		for(i=0;i<m;i++)
			scanf("%d",&B[i]);
		for(i=0;i<n;i++)
			scanf("%d",&C[i]);
		
		printf("Case %d:\n",p++);
		scanf("%d",&s);
		int len=0;
		for(i=0;i<l;i++)
			for(j=0;j<m;j++)
				num[len++]=A[i]+B[j];
		sort(num,num+len);
		sort(C,C+n);	
		while(s--)
		{
			k=0;
			scanf("%d",&x);
//			if(x<num[0]+C[0]||x>num[len-1]+C[n-1])
//			{
//				printf("NO\n");
//				continue;
//			}	
			for(i=0;i<n;i++)
			{
				le=0;r=len-1;
				while(le<=r)
				{
					mid=(le+r)/2;
					if(x-num[mid]==C[i])
					{
						k=1;
						break;
					}
					else if(x-num[mid]<C[i])
						r=mid-1;
					else
						le=mid+1;
				}
				if(k)
					break;	
			}
			if(k)
				printf("YES\n");
			else
				printf("NO\n");	
		}
	}
	return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

HDU 2141~ ??Can you find it? 还是二分法~~??????

标签:hdu   二分法   

原文地址:http://blog.csdn.net/lin14543/article/details/47156065

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!