码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3468 A Simple Problem with Integers (线段树 区间更新)

时间:2015-07-31 01:28:21      阅读:93      评论:0      收藏:0      [点我收藏+]

标签:poj   线段树区间更新   


A Simple Problem with Integers
Time Limit: 5000MS   Memory Limit: 131072K
Total Submissions: 75143   Accepted: 23146
Case Time Limit: 2000MS

Description

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of Aa, Aa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of Aa, Aa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

Source

POJ Monthly--2007.11.25, Yang Yi

题目链接:http://poj.org/problem?id=3468

题目大意:给一串数,C操作对区间累加值,Q操作查询区间和

题目分析:裸的线段树区间更新问题


#include <cstdio>
#include <cstring>
#include <algorithm>
#define lson l, mid, rt << 1
#define rson mid + 1, r, rt << 1 | 1
#define ll long long
using namespace std;
int const MAX = 1e5 + 5;
ll lazy[4 * MAX], sum[4 * MAX];

void PushUp(int rt)
{
    sum[rt] = sum[rt << 1] + sum[rt << 1 | 1];
}

void PushDown(int l, int r, int rt)
{
    if(lazy[rt])
    {
        int mid = (l + r) >> 1;
        sum[rt << 1] += lazy[rt] * (ll)(mid - l + 1);
        sum[rt << 1 | 1] += lazy[rt] * (ll)(r - mid);
        lazy[rt << 1] += lazy[rt];
        lazy[rt << 1 | 1] += lazy[rt];
        lazy[rt] = 0;
    }
}

void Build(int l, int r, int rt)
{
    lazy[rt] = 0;
    if(l == r)
    {
        scanf("%lld", &sum[rt]);
        return;
    }
    int mid = (l + r) >> 1;
    Build(lson);
    Build(rson);
    PushUp(rt);
}

void Update(int tl, int tr, int c, int l, int r, int rt)
{
    if(tl > r || tr < l)
        return;
    if(tl <= l && r <= tr)
    {
        sum[rt] += (ll)(r - l + 1) * c;
        lazy[rt] += c;
        return;
    }
    PushDown(l, r, rt);
    int mid = (l + r) >> 1;
    Update(tl, tr, c, lson);
    Update(tl, tr, c, rson);
    PushUp(rt);
}

ll Query(int tl, int tr, int l, int r, int rt)
{
    if(tl > r || tr < l)
        return 0;
    if(tl <= l && r <= tr)
        return sum[rt];
    PushDown(l, r, rt);
    int mid = (l + r) >> 1;
    return Query(tl, tr, lson) + Query(tl, tr, rson);
}

int main()
{
    int n, q;
    scanf("%d %d", &n, &q);
    Build(1, n, 1);
    while(q--)
    {
        char s[2];
        scanf("%s", s);
        if(s[0] == 'Q')
        {
            int l, r;
            scanf("%d %d", &l, &r);
            printf("%lld\n", Query(l, r, 1, n, 1));
        }
        else
        {
            int l, r, c;
            scanf("%d %d %d", &l, &r, &c);
            Update(l, r, c, 1, n, 1);
        }
    }
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

POJ 3468 A Simple Problem with Integers (线段树 区间更新)

标签:poj   线段树区间更新   

原文地址:http://blog.csdn.net/tc_to_top/article/details/47159753

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!