码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1698 Just a Hook (线段树 区间更新基础)

时间:2015-07-31 01:30:36      阅读:186      评论:0      收藏:0      [点我收藏+]

标签:hdu   线段树区间更新   


Just a Hook

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 21856    Accepted Submission(s): 10963

Problem Description

In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.

技术分享


Now Pudge wants to do some operations on the hook.
Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:
For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.
Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
 
Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
 
Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
 
Sample Input
1 10 2 1 5 2 5 9 3
 
Sample Output
Case 1: The total value of the hook is 24.
 
Source
2008 “Sunline Cup” National Invitational Contest

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1698

题目大意:开始区间1-n值都为1,x y z表示把区间[x, y]的值都改成z,最后输出区间和

题目分析:基础的线段树区间更新

#include <cstdio>
#include <cstring>
#include <algorithm>
#define lson l, mid, rt << 1
#define rson mid + 1, r, rt << 1 | 1
int const MAX = 100005;
int sum[4 * MAX], lazy[4 * MAX];
int n;

void PushUp(int rt)
{
    sum[rt] = sum[rt << 1] + sum[rt << 1 | 1];
}

void PushDown(int l, int r, int rt)
{
    if(lazy[rt])
    {
        int mid = (l + r) >> 1;
        lazy[rt << 1] = lazy[rt];
        lazy[rt << 1 | 1] = lazy[rt];
        sum[rt << 1] = lazy[rt] * (mid - l + 1);
        sum[rt << 1 | 1] = lazy[rt] * (r - mid);
        lazy[rt] = 0; 
    }
}

void Build(int l, int r, int rt)
{
    lazy[rt] = 0;
    if(l == r)
    {
        sum[rt] = 1;
        return;
    }
    int mid = (l + r) >> 1;
    Build(lson);
    Build(rson);
    PushUp(rt);
}

void Update(int L, int R, int c, int l, int r, int rt)
{
    if(r < L || l > R)
        return;
    if(L <= l && r <= R)
    {
        lazy[rt] = c;
        sum[rt] = c * (r - l + 1);
        return;
    }
    PushDown(l, r, rt);
    int mid = (l + r) >> 1;
    if(L <= mid)
        Update(L, R, c, lson);
    if(R > mid)
        Update(L, R, c, rson);
    PushUp(rt);
}

int main()
{
    int T;
    scanf("%d", &T);
    for(int ca = 1; ca <= T; ca++)
    {
        scanf("%d", &n);
        Build(1, n, 1);
        int q;
        scanf("%d", &q);
        while(q--)
        {
            int l, r, c;
            scanf("%d %d %d", &l, &r, &c);
            Update(l, r, c, 1, n, 1);
        }
        printf("Case %d: The total value of the hook is %d.\n", ca, sum[1]);
    }
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

HDU 1698 Just a Hook (线段树 区间更新基础)

标签:hdu   线段树区间更新   

原文地址:http://blog.csdn.net/tc_to_top/article/details/47158743

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!