码迷,mamicode.com
首页 > 其他好文 > 详细

HDU--5327 Olympiad

时间:2015-07-31 14:57:40      阅读:139      评论:0      收藏:0      [点我收藏+]

标签:acm   hdu   杭电   

Olympiad

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 347    Accepted Submission(s): 257


Problem Description
You are one of the competitors of the Olympiad in numbers. The problem of this year relates to beatiful numbers. One integer is called beautiful if and only if all of its digitals are different (i.e. 12345 is beautiful, 11 is not beautiful and 100 is not beautiful). Every time you are asked to count how many beautiful numbers there are in the interval [a,b] (ab). Please be fast to get the gold medal!
 

Input
The first line of the input is a single integer T (T1000), indicating the number of testcases.

For each test case, there are two numbers a and b, as described in the statement. It is guaranteed that 1ab100000.
 

Output
For each testcase, print one line indicating the answer.
 

Sample Input
2 1 10 1 1000
 

Sample Output
10 738
 

Author
XJZX
 

Source
2015 Multi-University Training Contest 4


本题就是关于判定一个数中是否包含有有重复的数字并求出一个区间内满足条件 的书的个数;
暴搜超时,每一个区间都算一遍浪费时间,直接先算出每一个数字之前满足条件的数字个数即可,打表法
#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

int temp[10];
int ans[100001];
int i,j,n,a,b;

int fun1(int x)//用于判断数字是否满足条件
{
    int mod;
    memset(temp,0,sizeof(temp));
    while(x != 0)
    {
        mod = x % 10;
        if(temp[mod])
        {
            return 0;
        }
        else
        {
            temp[mod]++;
        }
        x /= 10;
    }
    return 1;
}
int main()
{
    //结果打表
    for(i = 1;i < 100001;i++)
    {
        if(fun1(i))
        {
            ans[i] = ans[i-1] + 1;
        }
        else
        {
            ans[i] = ans[i-1];
        }
    }

    scanf("%d",&n);
    for(i = 0;i < n;i++)
    {
        scanf("%d%d",&a,&b);
        printf("%d\n",ans[b] - ans[a] + fun1(a));//区间相减即可
    }
    return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

HDU--5327 Olympiad

标签:acm   hdu   杭电   

原文地址:http://blog.csdn.net/litter_limbo/article/details/47168625

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!