标签:
Description
Input
Output
Sample Input
2 1 #. .# 4 4 ...# ..#. .#.. #... -1 -1
Sample Output
2 1
解题思路:这种题目最好用DFS解题,它是通过递归调用来实现自己的。用数组进行标记时最好将数组的声明放到主函数外面,因为C语言的全局变量在没有赋值以前默认为0,所以放到外面会更加方便。
程序代码:
#include<cstdio>
#include <iostream>
#include<cstring>
using namespace std;
int n,k,ans;
char map[12][12];
int vis[12];
int dfs(int i,int cur)
{
if(cur>=k)
{
ans++;
return 0;
}
int a,b;
for(a=i;a<n;a++)
{
for(b=0;b<n;b++)
{
if(!vis[b] && map[a][b]==‘#‘)
{
vis[b]=1;//标记
dfs(a+1,cur+1);//递归
vis[b]=0;
}
}
}
return 0;
}
int main()
{
while(scanf("%d%d",&n,&k)&&n!=-1)
{
ans=0;
memset(map,0,sizeof(map));
memset(vis,0,sizeof(vis));
for(int i=0;i<n;i++)
scanf("%s",map[i]);
dfs(0,0);
printf("%d\n",ans);
}
return 0;
}
标签:
原文地址:http://www.cnblogs.com/chenchunhui/p/4693021.html