码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 5224 Tom and Paper

时间:2015-07-31 20:25:13      阅读:116      评论:0      收藏:0      [点我收藏+]

标签:

Description

There is a piece of paper in front of Tom, its length and width are integer. Tom knows the area of this paper, he wants to know the minimum perimeter of this paper.
 

Input

In the first line, there is an integer T indicates the number of test cases. In the next T lines, there is only one integer n in every line, indicates the area of paper. 
技术分享技术分享技术分享技术分享技术分享技术分享技术分享技术分享技术分享技术分享
 

Output

For each case, output a integer, indicates the answer.
 

Sample Input

3 2 7 12
 

Sample Output

6 16 14
 
题意:
输入一张矩形纸的面积,求出其最小周长。
思路:
直接暴力求解,如果用两重循环,会超时,换成一重循环则不会。
代码:
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
int main()
{
    int T;
    int n;
    double x;
    int y;
    scanf("%d",&T);
    while(T--)
    {
        int   ans=2*1000000000;
        scanf("%d",&n);
        x=sqrt(n);
        for(int i=1;i<=x;i++)
        {
           if(n%i==0)
           {
               y=n/i;
               ans=min(ans,2*(i+y));
           }

        }

         printf("%d\n",ans);



    }
    return 0 ;
}

 
 
 
 
 
 
 
 

版权声明:本文为博主原创文章,未经博主允许不得转载。

hdu 5224 Tom and Paper

标签:

原文地址:http://blog.csdn.net/a1967919189/article/details/47173955

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!