码迷,mamicode.com
首页 > 其他好文 > 详细

How Many Tables-并查集

时间:2015-07-31 20:26:34      阅读:128      评论:0      收藏:0      [点我收藏+]

标签:

HDU - 1213
Time Limit: 1000MS   Memory Limit: 32768KB   64bit IO Format: %I64d & %I64u

 Status

Description

Today is Ignatius‘ birthday. He invites a lot of friends. Now it‘s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers. 

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table. 

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least. 
 

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases. 
 

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks. 
 

Sample Input

2 5 3 1 2 2 3 4 5 5 1 2 5
 

Sample Output

2 4
题目目的很简单就是让你求有几个集合
所以直接模板飘过
/*
Author: 2486
Memory: 1420 KB		Time: 0 MS
Language: G++		Result: Accepted
*/
#include <cstring>
#include <string>
#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
const int maxn=1000+5;
int a,b,T,N,M,par[maxn],ranks[maxn];
void init(int sizes) {
    for(int i=1; i<=sizes; i++) {
        par[i]=i;
        ranks[i]=1;
    }
}
int find(int x) {
    return par[x]==x?x:par[x]=find(par[x]);
}
bool same(int x,int y) {
    return find(x)==find(y);
}
void unite(int x,int y) {
    x=find(x);
    y=find(y);
    if(x==y)return ;
    if(ranks[x]>ranks[y]) {
        par[y]=x;
    } else {
        par[x]=y;
        if(ranks[x]==ranks[y])ranks[x]++;
    }
}
int main() {
    scanf("%d",&T);
    while(T--) {
        scanf("%d",&N);
        scanf("%d",&M);
        init(N);
        for(int i=0; i<M; i++) {
            scanf("%d%d",&a,&b);
            unite(a,b);
        }
        int ans=0;
        for(int i=1; i<=N; i++) {
            if(par[i]==i)ans++;
        }
        printf("%d\n",ans);
    }
    return 0;
}


 

版权声明:本文为博主原创文章,未经博主允许不得转载。

How Many Tables-并查集

标签:

原文地址:http://blog.csdn.net/qq_18661257/article/details/47173935

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!