码迷,mamicode.com
首页 > 其他好文 > 详细

HDU-5319 Painter

时间:2015-08-01 11:23:56      阅读:77      评论:0      收藏:0      [点我收藏+]

标签:

http://acm.hdu.edu.cn/showproblem.php?pid=5319

Painter

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 956    Accepted Submission(s): 435

Problem Description
Mr. Hdu is an painter, as we all know, painters need ideas to innovate , one day, he got stuck in rut and the ideas dry up, he took out a drawing board and began to draw casually. Imagine the board is a rectangle, consists of several square grids. He drew diagonally, so there are two kinds of draws, one is like ‘\’ , the other is like ‘/’. In each draw he choose arbitrary number of grids to draw. He always drew the first kind in red color, and drew the other kind in blue color, when a grid is drew by both red and blue, it becomes green. A grid will never be drew by the same color more than one time. Now give you the ultimate state of the board, can you calculate the minimum time of draws to reach this state.
 
Input
The first line is an integer T describe the number of test cases. Each test case begins with an integer number n describe the number of rows of the drawing board. Then n lines of string consist of ‘R’ ‘B’ ‘G’ and ‘.’ of the same length. ‘.’ means the grid has not been drawn. 1<=n<=50 The number of column of the rectangle is also less than 50. Output Output an integer as described in the problem description.
 
Output
Output an integer as described in the problem description.
 
Sample Input
2
4
RR.B
.RG.
.BRR
B..R
4
RRBB
RGGB
BGGR
BBRR
 
Sample Output
3
6
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 55;
int N,m;
char G[maxn][maxn];
 bool check(char a, char b)
 {
       if(a == b || a == G)
              return true;
        else
             return false;
}
int solve() {
    int ret = 0;

    for (int i = 0; i < N; i++) {

        for (int j = 0; j < m; j++) {
            if (check(G[i][j], R) && !check(G[i-1][j-1], R))
               ret++;
            if (check(G[i][j], B) && !check(G[i-1][j+1], B))
               ret++;
        }
    }
    return ret;
}

     int main () {
   int cas;
    scanf("%d", &cas);
   while(cas--) {
        scanf("%d", &N);
        memset(G, 0, sizeof(G));
       for (int i = 0; i < N; i++)
            scanf("%s", G[i]);
              m = strlen(G[0]) ;
          printf("%d\n", solve());
 }
    return 0;
}

 

HDU-5319 Painter

标签:

原文地址:http://www.cnblogs.com/cancangood/p/4693820.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!