码迷,mamicode.com
首页 > 其他好文 > 详细

hdoj-5120-Intersection【数论】

时间:2015-08-01 12:59:43      阅读:118      评论:0      收藏:0      [点我收藏+]

标签:

Intersection

Time Limit: 4000/4000 MS (Java/Others) Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 964 Accepted Submission(s): 368


Problem Description
Matt is a big fan of logo design. Recently he falls in love with logo made up by rings. The following figures are some famous examples you may know.

技术分享

A ring is a 2-D figure bounded by two circles sharing the common center. The radius for these circles are denoted by r and R (r < R). For more details, refer to the gray part in the illustration below.

技术分享

Matt just designed a new logo consisting of two rings with the same size in the 2-D plane. For his interests, Matt would like to know the area of the intersection of these two rings.

Input
The first line contains only one integer T (T ≤ 105), which indicates the number of test cases. For each test case, the first line contains two integers r, R (0 ≤ r < R ≤ 10).

Each of the following two lines contains two integers xi, yi (0 ≤ xi, yi ≤ 20) indicating the coordinates of the center of each ring.

Output
For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1) and y is the area of intersection rounded to 6 decimal places.

Sample Input
2 2 3 0 0 0 0 2 3 0 0 5 0

Sample Output
Case #1: 15.707963 Case #2: 2.250778

Source

Recommend
liuyiding | We have carefully selected several similar problems for you: 5338 5337 5336 5335 5334

注意: Pi 不能自己写,要用acos(-1.0) ,在这里WA了好多次

#include<stdio.h>
#include<math.h>
#include<algorithm>
using namespace std;
double dis,R,r;
struct point{
	double x,y;
}a,b;
const double pi=acos(-1.0);
double S(double r1,double r2){
	if(dis>=(r1+r2)) return 0; //外切或不相交 
	double s1,s2,sit1,sit2; 
	if(dis<=fabs(r1-r2)){  //内切或内含 
		r1=min(r1,r2);
	    return pi*r1*r1; 
	}
	s1=(r1*r1+dis*dis-r2*r2)/(2*r1*dis);
	s2=(r2*r2+dis*dis-r1*r1)/(2*r2*dis);
    sit1=acos(s1);
    sit2=acos(s2);
	return sit1*r1*r1+sit2*r2*r2-r1*dis*sin(sit1);
	 
}
int main(){
	int t,cas=0;
	scanf("%d",&t);
	while(t--){
		++cas;
		scanf("%lf%lf",&r,&R);
		scanf("%lf%lf",&a.x,&a.y);
		scanf("%lf%lf",&b.x,&b.y);
	    dis=sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
	    if(fabs(dis)<1e-7){
	    	printf("Case #%d: %.6lf\n",cas,pi*(R*R-r*r));
	    	continue;
	    }
		double ss=0;
		ss=S(R,R);
		ss-=2*S(R,r)-S(r,r);
		printf("Case #%d: %.6lf\n",cas,ss);
	}
	return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

hdoj-5120-Intersection【数论】

标签:

原文地址:http://blog.csdn.net/qq_18062811/article/details/47185239

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!