码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 5122 K.Bro Sorting

时间:2015-08-01 15:45:17      阅读:98      评论:0      收藏:0      [点我收藏+]

标签:

K.Bro Sorting

Time Limit: 2000/2000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 1041    Accepted Submission(s): 460


Problem Description
Matt’s friend K.Bro is an ACMer.

Yesterday, K.Bro learnt an algorithm: Bubble sort. Bubble sort will compare each pair of adjacent items and swap them if they are in the wrong order. The process repeats until no swap is needed.

Today, K.Bro comes up with a new algorithm and names it K.Bro Sorting.

There are many rounds in K.Bro Sorting. For each round, K.Bro chooses a number, and keeps swapping it with its next number while the next number is less than it. For example, if the sequence is “1 4 3 2 5”, and K.Bro chooses “4”, he will get “1 3 2 4 5” after this round. K.Bro Sorting is similar to Bubble sort, but it’s a randomized algorithm because K.Bro will choose a random number at the beginning of each round. K.Bro wants to know that, for a given sequence, how many rounds are needed to sort this sequence in the best situation. In other words, you should answer the minimal number of rounds needed to sort the sequence into ascending order. To simplify the problem, K.Bro promises that the sequence is a permutation of 1, 2, . . . , N .
 

Input
The first line contains only one integer T (T ≤ 200), which indicates the number of test cases. For each test case, the first line contains an integer N (1 ≤ N ≤ 106).

The second line contains N integers ai (1 ≤ ai ≤ N ), denoting the sequence K.Bro gives you.

The sum of N in all test cases would not exceed 3 × 106.
 

Output
For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1), y is the minimal number of rounds needed to sort the sequence.
 

Sample Input
2 5 5 4 3 2 1 5 5 1 2 3 4
 

Sample Output
Case #1: 4 Case #2: 1
Hint
In the second sample, we choose “5” so that after the ?rst round, sequence becomes “1 2 3 4 5”, and the algorithm completes.
 

Source
 


给出一个数列,每次随机选择一个数,按照冒泡排序的方法去交换,问这种排序最快需要几个回合
思路:如果某个数右边有比他小的数字,那这个数一定要被扔到后边去。所以线性方法统计有多少个这样的数字即可 

#include<stdio.h>
int a[1000005];
int main()
{
	int t,i,n,ans,v=1;
	scanf("%d",&t);
	while(t--){
		scanf("%d",&n);
		for(i=1;i<=n;i++){
			scanf("%d",&a[i]);
		}
		int temp=a[i-1];
		ans=0;
		for(i--;i>=1;i--){
			if(temp<a[i])
				ans++;
			else
				temp=a[i];
		}
		printf("Case #%d: %d\n",v++,ans);
	}
	return 0;
 } 


hdu 5122 K.Bro Sorting

标签:

原文地址:http://blog.csdn.net/ling_du/article/details/47186541

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!