码迷,mamicode.com
首页 > 其他好文 > 详细

HDU3714——三分——Error Curves

时间:2015-08-01 17:00:35      阅读:118      评论:0      收藏:0      [点我收藏+]

标签:

Josephina is a clever girl and addicted to Machine Learning recently. She 
pays much attention to a method called Linear Discriminant Analysis, which 
has many interesting properties. 
In order to test the algorithm‘s efficiency, she collects many datasets. 
What‘s more, each data is divided into two parts: training data and test 
data. She gets the parameters of the model on training data and test the 
model on test data. To her surprise, she finds each dataset‘s test error curve is just a parabolic curve. A parabolic curve corresponds to a quadratic function. In mathematics, a quadratic function is a polynomial function of the form f(x) = ax2 + bx + c. The quadratic will degrade to linear function if a = 0. 

技术分享


It‘s very easy to calculate the minimal error if there is only one test error curve. However, there are several datasets, which means Josephina will obtain many parabolic curves. Josephina wants to get the tuned parameters that make the best performance on all datasets. So she should take all error curves into account, i.e., she has to deal with many quadric functions and make a new error definition to represent the total error. Now, she focuses on the following new function‘s minimum which related to multiple quadric functions. The new function F(x) is defined as follows: F(x) = max(Si(x)), i = 1...n. The domain of x is [0, 1000]. Si(x) is a quadric function. Josephina wonders the minimum of F(x). Unfortunately, it‘s too hard for her to solve this problem. As a super programmer, can you help her?
 

Input

The input contains multiple test cases. The first line is the number of cases T (T < 100). Each case begins with a number n (n ≤ 10000). Following n lines, each line contains three integers a (0 ≤ a ≤ 100), b (|b| ≤ 5000), c (|c| ≤ 5000), which mean the corresponding coefficients of a quadratic function.
 

Output

For each test case, output the answer in a line. Round to 4 digits after the decimal point.
 

Sample Input

2 1 2 0 0 2 2 0 0 2 -4 2
 

Sample Output

0.0000 0.5000
 
/*
三分适用于抛物线类型的,先增后减或者先减后增
精度问题。。

*/
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

const double eps = 1e-15;
const int MAX = 1e4 + 10;
int a[MAX], b[MAX], c[MAX];
int n;
double  check(double x)
{
    double max1 = a[1]*x*x + b[1]*x + c[1];
    for(int i = 2; i <= n ; i++)
        max1 = max(max1, a[i]*x*x + b[i]*x + c[i]);
    return max1;
}
    
int main()
{
int T;
scanf("%d", &T);
while(T--){
    scanf("%d", &n);
    for(int i = 1; i <= n ; i++){
        scanf("%d%d%d", &a[i], &b[i], &c[i]);
    }
    double l = 0, r = 1000;
    while(l + eps < r){
        double mid = (l + r) / 2;
        double midmid = (mid + r) /2 ;
        if(check(mid) > check(midmid)){
            l = mid;
        }
        else r = midmid;
    }
    printf("%.4f\n",check(r));
}
return 0;
}

  

HDU3714——三分——Error Curves

标签:

原文地址:http://www.cnblogs.com/zero-begin/p/4694158.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!