码迷,mamicode.com
首页 > 其他好文 > 详细

HDU杭电4883 TIANKENG’s restaurant

时间:2015-08-01 18:57:47      阅读:70      评论:0      收藏:0      [点我收藏+]

标签:

Problem Description
TIANKENG manages a restaurant after graduating from ZCMU, and tens of thousands of customers come to have meal because of its delicious dishes. Today n groups of customers come to enjoy their meal, and there are Xi persons in the ith group in sum. Assuming that each customer can own only one chair. Now we know the arriving time STi and departure time EDi of each group. Could you help TIANKENG calculate the minimum chairs he needs to prepare so that every customer can take a seat when arriving the restaurant?
 

Input
The first line contains a positive integer T(T<=100), standing for T test cases in all.

Each cases has a positive integer n(1<=n<=10000), which means n groups of customer. Then following n lines, each line there is a positive integer Xi(1<=Xi<=100), referring to the sum of the number of the ith group people, and the arriving time STi and departure time Edi(the time format is hh:mm, 0<=hh<24, 0<=mm<60), Given that the arriving time must be earlier than the departure time.

Pay attention that when a group of people arrive at the restaurant as soon as a group of people leaves from the restaurant, then the arriving group can be arranged to take their seats if the seats are enough.
 

Output
For each test case, output the minimum number of chair that TIANKENG needs to prepare.
 

Sample Input
2 2 6 08:00 09:00 5 08:59 09:59 2 6 08:00 09:00 5 09:00 10:00
 

Sample Output
11 6
 

//我在比赛时写的代码,又错了,思路我觉得没有错,知道的大神帮我纠正一下

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct people
{
    char st[20];//来的时间
    char et[20];//走的时间
    int sum;
}arr[10010];
bool cmp(people a,people b)
{
    return strcmp(a.et,b.et)<0;
}
int main()
{
    int t,n,i;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(i=0;i<n;++i)
            scanf("%d %s %s",&arr[i].sum,arr[i].st,arr[i].et);//以前写过一道题,这个时间可以用字符串比较,因为是按照一定格式写的,所以以字符串输入没问题
        sort(arr,arr+n,cmp);
        int cnt=arr[0].sum;
        
        for(i=1;i<n;++i)
        {
            if(strcmp(arr[i-1].et,arr[i].st)>0)//如果有公共部分
            {
                cnt+=arr[i].sum;
            }
            else
            {
                cnt=arr[i].sum>cnt?arr[i].sum:cnt;
            }
        }
        printf("%d\n",cnt);
    }
    return 0;
}


//ac代码

/*
题意为:用最少的座位数迎接在不同时间段来的客人 

*/
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int a[1000010];
int main()
{
	int t,n,s;
	int i,j;
	int max;
	int hour1,hour2,min1,min2; 
	scanf("%d",&t);
	while(t--)
	{
		memset(a,0,sizeof(a));//一开始要清零 
		scanf("%d",&n);
		max=-100;//纪录最小的座位 
		for(i=0;i<n;++i)
		{
			scanf("%d %d:%d %d:%d",&s,&hour1,&min1,&hour2,&min2);//s表示这个时间段来的人数 
			int sum1=hour1*60+min1;//每个时间都有一个sum1和sum2这个区间 
			int sum2=hour2*60+min2;
			
			for(j=sum1;j<sum2;++j)//当两区间有公共部分时,数组a[i]刚才也存了一个数了 
			{
				a[j]+=s;
				if(a[j]>max)//当数组a纪录的座位数大于max,要把max更新 
					max=a[j];
			}
		}
		printf("%d\n",max);	
	}
	return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

HDU杭电4883 TIANKENG’s restaurant

标签:

原文地址:http://blog.csdn.net/yuzhiwei1995/article/details/47188817

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!