标签:
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 58883 Accepted Submission(s): 18392
Problem Description
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are
summed and the process is repeated. This is continued as long as necessary to obtain a single digit.
For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process
must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.
Input
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.
Output
For each integer in the input, output its digital root on a separate line of the output.
Sample Input
Sample Output
刚开始没有考虑到该数字的大小,用int a;进行做题,提交时错了,后来发现应该用字符串以便储存更大的数。
#include<stdio.h>
#include<string.h>
int main()
{
int b,c,sum,n,m,i,j,k;
char a[1000];
while(scanf("%s",&a))
{
if(a[0]=='0')
break;
j=strlen(a);
sum=0;
for(i=0;i<j;i++)
sum+=a[i]-'0';
if(sum>=10)
{
while(sum>=10)
{
c=sum%10;
sum=sum/10+c;
}
}
printf("%d\n",sum);
}
return 0;
}
版权声明:本文为博主原创文章,未经博主允许不得转载。
Digital Roots
标签:
原文地址:http://blog.csdn.net/l15738519366/article/details/47188487