码迷,mamicode.com
首页 > 其他好文 > 详细

poj3253 Fence Repair【哈夫曼树+优先队列】

时间:2015-08-01 19:03:34      阅读:89      评论:0      收藏:0      [点我收藏+]

标签:

Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn‘t own a saw with which to cut the wood, so he mosies over to Farmer Don‘s Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn‘t lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer N, the number of planks 
Lines 2..N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

Sample Input

3
8
5
8

Sample Output

34

Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 

The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).



//这是比赛时写的代码,答案虽然对的,但有问题

//不是把一个长度为21的砍开吗?我就想着一个开始是21,先砍成8和13,需要21,然后再把13砍成8和5,需要13  13+21=34;然后我就把数组里的素

//从大到小排列,为的是21加的更少,花的金币就更少,就从大到小排列,


//然而错了n次,比赛结束后我看了看别人的代码,是哈夫曼树+优先队列,每次取两最小的数,粘成一个长的,每次都这样


//但我不知道我的代码错在哪

#include<cstdio>
#include<algorithm>
using namespace std;
int cmp(__int64 x,__int64 y)
{
    return x>y;
}
__int64 a[20100];
int main()
{
    int n,i;
    while(~scanf("%d",&n))
    {
        __int64 s=0;
        for(i=0;i<n;++i)        
        {
            scanf("%I64d",a+i);
            s+=a[i];
        }                
        sort(a,a+n,cmp);
        __int64 sum=0;
        for(i=0;i<n;++i)
        {
            if(s!=a[n-1])
            {
                sum+=s;
                s-=a[i];
            }            
        }
        printf("%I64d\n",sum);
    }
}



/*
题意:将一块木块砍一刀,当前木块是多长就需要多少金币,
求花最少的金币砍成你想要的木块长度 
*/
//哈夫曼树+优先队列 poj 3253 

//每次实现最小的两个数相加 
#include<cstdio>
#include<algorithm>
#include<queue>
using namespace std;

int main()
{
	int n,i;
	__int64 a,b;
	__int64 m;
	scanf("%d",&n);
	{
		priority_queue<__int64,vector<__int64>,greater<__int64> >q;
		
		for(i=0;i<n;++i)		
		{
			scanf("%I64d",&m);
			q.push(m);
		}								
		__int64 sum=0;
		while(q.size()>1)
		{
			a=q.top();
			q.pop();
			b= q.top();
			q.pop();
			sum+=a+b;			
			q.push(a+b);	
		}
		printf("%I64d\n",sum);
	}
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

poj3253 Fence Repair【哈夫曼树+优先队列】

标签:

原文地址:http://blog.csdn.net/yuzhiwei1995/article/details/47188431

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!