码迷,mamicode.com
首页 > 其他好文 > 详细

哈理工2015 暑假训练赛 zoj 2976 Light Bulbs

时间:2015-08-02 23:26:11      阅读:212      评论:0      收藏:0      [点我收藏+]

标签:zoj   acm   编程   算法   

 Light BulbsTime Limit:2000MS    Memory Limit:65536KB    64bit IO Format:%lld & %llu

Description

Wildleopard had fallen in love with his girlfriend for 20 years. He wanted to end the long match for their love and get married this year. He bought a new house for his family and hired a company to decorate his house. Wildleopard and his fiancee were very satisfied with the postmodern design, except the light bulbs. Varieties of light bulbs were used so that the light in the house differed a lot in different places. Now he asks you, one of his best friends, to help him find out the point of maximum illumination.

To simplify the problem, we can assume each bulb is a point light source and we only need to consider the grid points of the flat floor of the house. A grid point is a point whose coordinates are both integers. The length and the width of house can be considered infinite. Illumination means the amount of light that go through in one unit area. The illumination of a point can be calculated by simply adding the illumination from each source. The illumination from a source can be calculated by the following equation:

技术分享技术分享

, where E is the illumination of the point, I is the luminous intensity of the source, R is the distance between the source and the point and i is the angle between the normal of the plane and the light to the point.

Given the position and the luminous intensity of the light bulbs, you are asked to find the maximum illumination on the floor at the grid points.

Input

Standard input will contain multiple test cases. The first line of the input is a single integer T (1 <= T <= 20) which is the number of test cases. And it will be followed by T consecutive test cases.

The first line of each test case contains one integer n(1 <= n <= 100), indicating the number of bulbs of the lamps in the house. The next n lines will contain 4 integers each, Xi, Yi, Zi, Ii, separated by one space, indicating the coordinates and the luminous intensity of the i-th bulb of the lamp. The absolute values of the coordinates do not exceed 100 and Zi is always positive. Ii is a positive integer less than 32768.

Output

Results should be directed to standard output. The output of each test case should be a real number rounded to 0.01, which is the maximum illumination on the floor at the grid points.

Sample Input

3
1
0 0 1 100
4
1 0 1 100
0 1 1 100
-1 0 1 100
0 -1 1 100
4
1 0 100 10000
0 1 100 10000
-1 0 100 10000
0 -1 100 10000

Sample Output

100.00
147.43
4.00


这个大水题啊 赛后迅速1 a  不过有啥用啊  ~  当时因为少看了一个条件,他给定了枚举范围 ,那么这就好办了…… 只需枚举-100  到100 矩形区域内的点即可
另外注意坐标系建立的时候不能使下标为负,那么我们就可以把原点建在(-100,100)上。然后三重循环搞定。
 
#include<iostream>
#include<sstream>
#include<algorithm>
#include<cstdio>
#include<string.h>
#include<cctype>
#include<string>
#include<cmath>
#include<vector>
#include<stack>
#include<queue>
#include<map>
#include<set>
using namespace std;
const int INF=102;
double cnt[2*INF+5][2*INF+5];

double A(double x)
{
    return x*x;
}
double dis(double x1,double y1,double z1,double x2,double y2,double z2 )
{

    return sqrt(A(x1-x2)+A(y1-y2)+A(z1-z2));
}
int main()
{
    int t;cin>>t;
    while(t--)
    {
        memset(cnt,0,sizeof(cnt));
        int n;cin>>n;
        for(int i=0;i<n;i++)
        {
            double x,y,z,I;scanf("%lf%lf%lf%lf",&x,&y,&z,&I);
            for(int i=0;i<=2*INF;i++)
            {
                for(int j=0;j<=2*INF;j++)
                {

                    double R=dis(x,y,z,i-INF,j-INF,0);
                    double t=z/R;
                    cnt[i][j]+=(I/(R*R))*t;
                }

            }
        }
      double ans=-1;
      for(int i=0;i<=2*INF;i++)
      {
          for(int j=0;j<=2*INF;j++)
          {
              //cout<<cnt[i][j]<<" ";
              ans=max(cnt[i][j],ans);
          }

      }
     printf("%.2lf\n",ans);
    }
    return 0;
}
/*
234
1
-102 -102 3
*/

版权声明:本文为博主原创文章,未经博主允许不得转载。

哈理工2015 暑假训练赛 zoj 2976 Light Bulbs

标签:zoj   acm   编程   算法   

原文地址:http://blog.csdn.net/lsgqjh/article/details/47213095

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!