码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 3549(网络流入门之最大流)

时间:2015-08-02 23:28:19      阅读:326      评论:0      收藏:0      [点我收藏+]

标签:acm算法   搜索   遍历   

Flow Problem

Time Limit: 5000/5000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 10327    Accepted Submission(s): 4866


Problem Description
Network flow is a well-known difficult problem for ACMers. Given a graph, your task is to find out the maximum flow for the weighted directed graph.
 

Input
The first line of input contains an integer T, denoting the number of test cases.
For each test case, the first line contains two integers N and M, denoting the number of vertexes and edges in the graph. (2 <= N <= 15, 0 <= M <= 1000)
Next M lines, each line contains three integers X, Y and C, there is an edge from X to Y and the capacity of it is C. (1 <= X, Y <= N, 1 <= C <= 1000)
 

Output
For each test cases, you should output the maximum flow from source 1 to sink N.
 

Sample Input
2 3 2 1 2 1 2 3 1 3 3 1 2 1 2 3 1 1 3 1
 

Sample Output
Case 1: 1 Case 2: 2
 

Author
HyperHexagon
 

Source

 


n个点m条边,找到1到n使得流量最大。

解题思路;找出所有的增广路径,然后再找增广路径上的边,找出最小的流量!!

#include <cstdio>
#include <cmath>
#include <queue>
#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;
int n,m;
int map1[1001][1001];
int pre[1001];
int vis[1001];
int s,t;
bool BFS()
{
    int i,cur;
    queue<int>q;
    memset(pre,0,sizeof(pre));
    memset(vis,0,sizeof(vis));
    vis[s]=1;
    q.push(s);
    while(!q.empty())
    {
        cur=q.front();
        q.pop();
        if(cur==t)
            return 1;
        for(i=1; i<=n; i++)
        {
            if(!vis[i] &&map1[cur][i])
            {
                q.push(i);
                pre[i]=cur;
                vis[i]=1;
            }
        }
    }
    return 0;
}//找增广路径
int Max_flow()
{
    int i,ans=0;
    while(1)
    {
        if(!BFS())
            return ans;
        int Min=0x7f7f7f7f;
        for(i=t; i!=s; i=pre[i])
            Min=min(Min,map1[pre[i]][i]);
        for(i=t; i!=s; i=pre[i])
        {
            map1[pre[i]][i]-=Min;
            map1[i][pre[i]]+=Min;
        }
        ans+=Min;
    }
}//找增广路径上的最小流量
int main()
{
    int T;
    cin>>T;
    int v,u,c;
    int k=1;
    while(T--)
    {
        scanf("%d%d",&n,&m);
        memset(map1,0,sizeof(map1));
        s=1,t=n;
        while(m--)
        {
            scanf("%d%d%d",&u,&v,&c);
            map1[u][v]+=c;
        }
        printf("Case %d: %d\n",k++,Max_flow());
    }
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

HDU 3549(网络流入门之最大流)

标签:acm算法   搜索   遍历   

原文地址:http://blog.csdn.net/sky_miange/article/details/47212261

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!